Hello,

We are moving some of our servers to use 16.04 and for all new installs I
have noticed that I am unable to fetch the ssh_authorized keys from the
server.

/usr/bin/sss_ssh_authorizedkeys --debug 10 -d prod.zzzzzzz.com ademaria
(Thu Oct  6 11:29:59:823635 2016) [/usr/bin/sss_ssh_authorizedkeys] [main]
(0x0020): sss_ssh_get_ent() failed (14): Bad address
Error looking up public keys

This only happens on Ubuntu 16.04. We have a number of 12.04 that work
perfectly.

The configuration seems ok or at least matches the one on 12.04.
I increased the debug level on sssd and sss_ssh and this is the output I get

(Thu Oct  6 15:42:01 2016) [sssd[ssh]] [sss_cmd_get_version] (0x0200):
Offered version [0].
(Thu Oct  6 15:42:01 2016) [sssd[ssh]] [reset_idle_timer] (0x4000): Idle
timer re-set for client [0x67b890][18]
(Thu Oct  6 15:42:01 2016) [sssd[ssh]] [reset_idle_timer] (0x4000): Idle
timer re-set for client [0x67b890][18]
(Thu Oct  6 15:42:01 2016) [sssd[ssh]] [reset_idle_timer] (0x4000): Idle
timer re-set for client [0x67b890][18]
(Thu Oct  6 15:42:01 2016) [sssd[ssh]] [ssh_cmd_parse_request] (0x0400):
Requested domain [prod.zzzzzzz]
(Thu Oct  6 15:42:01 2016) [sssd[ssh]] [ssh_cmd_parse_request] (0x0400):
Parsing name [ademaria][prod.zzzzzzz]
(Thu Oct  6 15:42:01 2016) [sssd[ssh]] [sss_parse_name_for_domains]
(0x0200): name 'ademaria' matched without domain, user is ademaria
(Thu Oct  6 15:42:01 2016) [sssd[ssh]] [sss_parse_name_for_domains]
(0x0200): using default domain [prod.zzzzzzz]
(Thu Oct  6 15:42:01 2016) [sssd[ssh]] [sss_ssh_cmd_get_user_pubkeys]
(0x0400): Requesting SSH user public keys for [ademaria] from [prod.zzzzzzz]
(Thu Oct  6 15:42:01 2016) [sssd[ssh]] [sss_dp_issue_request] (0x0400):
Issuing request for [0x40b850:1:ademaria@prod.zzzzzzz]
(Thu Oct  6 15:42:01 2016) [sssd[ssh]] [sss_dp_get_account_msg] (0x0400):
Creating request for [prod.zzzzzzz][0x1][BE_REQ_USER][1][name=ademaria]
(Thu Oct  6 15:42:01 2016) [sssd[ssh]] [sbus_add_timeout] (0x2000): 0x658390
(Thu Oct  6 15:42:01 2016) [sssd[ssh]] [sss_dp_internal_get_send] (0x0400):
Entering request [0x40b850:1:ademaria@prod.zzzzzzz]
(Thu Oct  6 15:42:01 2016) [sssd[ssh]] [sbus_remove_timeout] (0x2000):
0x658390
(Thu Oct  6 15:42:01 2016) [sssd[ssh]] [sbus_dispatch] (0x4000): dbus conn:
0x65a7b0
(Thu Oct  6 15:42:01 2016) [sssd[ssh]] [sbus_dispatch] (0x4000):
Dispatching.
(Thu Oct  6 15:42:01 2016) [sssd[ssh]] [sss_dp_get_reply] (0x1000): Got
reply from Data Provider - DP error code: 0 errno: 0 error message: Success
(Thu Oct  6 15:42:01 2016) [sssd[ssh]] [ssh_user_pubkeys_search_next]
(0x0400): Requesting SSH user public keys for [ademaria@prod.zzzzzzz]
(Thu Oct  6 15:42:01 2016) [sssd[ssh]] [ldb] (0x4000): Added timed event
"ltdb_callback": 0x666a00
(Thu Oct  6 15:42:01 2016) [sssd[ssh]] [ldb] (0x4000): Added timed event
"ltdb_timeout": 0x666ac0
(Thu Oct  6 15:42:01 2016) [sssd[ssh]] [ldb] (0x4000): Running timer event
0x666a00 "ltdb_callback"
(Thu Oct  6 15:42:01 2016) [sssd[ssh]] [ldb] (0x4000): Destroying timer
event 0x666ac0 "ltdb_timeout"
(Thu Oct  6 15:42:01 2016) [sssd[ssh]] [ldb] (0x4000): Ending timer event
0x666a00 "ltdb_callback"
(Thu Oct  6 15:42:01 2016) [sssd[ssh]] [decode_and_add_base64_data]
(0x4000): Mssing element, nothing to do.
(Thu Oct  6 15:42:01 2016) [sssd[ssh]] [decode_and_add_base64_data]
(0x4000): Mssing element, nothing to do.
(Thu Oct  6 15:42:01 2016) [sssd[ssh]] [cert_to_ssh_key] (0x0040):
NSS_InitContext failed [-8015].
(Thu Oct  6 15:42:01 2016) [sssd[ssh]] [decode_and_add_base64_data]
(0x0040): cert_to_ssh_key failed.
(Thu Oct  6 15:42:01 2016) [sssd[ssh]] [ssh_cmd_build_reply] (0x0040):
decode_and_add_base64_data failed.
(Thu Oct  6 15:42:01 2016) [sssd[ssh]] [ssh_cmd_done] (0x0020): Fatal
error, killing connection!
(Thu Oct  6 15:42:01 2016) [sssd[ssh]] [client_destructor] (0x2000):
Terminated client [0x67b890][18]
(Thu Oct  6 15:42:01 2016) [sssd[ssh]] [sss_dp_req_destructor] (0x0400):
Deleting request: [0x40b850:1:ademaria@prod.zzzzzzz]
(Thu Oct  6 15:42:10 2016) [sssd[ssh]] [sbus_dispatch] (0x4000): dbus conn:
0x6566b0
(Thu Oct  6 15:42:10 2016) [sssd[ssh]] [sbus_dispatch] (0x4000):
Dispatching.
(Thu Oct  6 15:42:10 2016) [sssd[ssh]] [sbus_message_handler] (0x2000):
Received SBUS method org.freedesktop.sssd.service.ping on path
/org/freedesktop/sssd/service
(Thu Oct  6 15:42:10 2016) [sssd[ssh]] [sbus_get_sender_id_send] (0x2000):
Not a sysbus message, quit
(Thu Oct  6 15:42:20 2016) [sssd[ssh]] [sbus_dispatch] (0x4000): dbus conn:
0x6566b0
(Thu Oct  6 15:42:20 2016) [sssd[ssh]] [sbus_dispatch] (0x4000):
Dispatching.
(Thu Oct  6 15:42:20 2016) [sssd[ssh]] [sbus_message_handler] (0x2000):
Received SBUS method org.freedesktop.sssd.service.ping on path
/org/freedesktop/sssd/service
(Thu Oct  6 15:42:20 2016) [sssd[ssh]] [sbus_get_sender_id_send] (0x2000):
Not a sysbus message, quit

Could you help me understand what is the issue with it?

Regards
Alessandro

-- 
Alessandro De Maria
alessandro.dema...@gmail.com
-- 
Manage your subscription for the Freeipa-users mailing list:
https://www.redhat.com/mailman/listinfo/freeipa-users
Go to http://freeipa.org for more info on the project

Reply via email to