Thanks Martin for the reply.

when i try 'ipa-client-install --uninstall' then i am getting bellow message:

ipa-client-install --uninstall
IPA client is configured as a part of IPA server on this system.
Refer to ipa-server-install for uninstallation.

How can i raise domain level to 1 in v4? i tried

ipa domainlevel-set 1

but i am getting ipa: ERROR: unknown command 'domainlevel-set'

Thanks again for your help on this.

Best Regards,

From: Martin Basti <>
Sent: Saturday, October 15, 2016 4:54 AM
To: Deepak Dimri;
Subject: Re: [Freeipa-users] Not able to pass through ipa-replica-install on 
centos 7

On 14.10.2016 18:58, Deepak Dimri wrote:

Hi All,

I am trying to configure replication between two FreeIPA centos 7 servers.  As 
per the document i need  same FreeIPA version running on both the machines, 
which i have, and run ipa-replica-prepare on the master and then simply run 
ipa-replica-install on the replica server along with replica file.  But i am 
unable to get pass the below error message:

[root@ip-172-31-23-230 ipa]# ipa-replica-install 

ipa.ipapython.install.cli.install_tool(Replica): ERROR    IPA client is already 
configured on this system.

Please uninstall it first before configuring the replica, using 
'ipa-client-install --uninstall'.

What should i be doing to get around this error? the error looks missleading as 
i am trying to install replica and not ipa client




have you tried ipa-client-install --uninstall?

Replica cannot be installed on system where client is already installed (with 
domain level 0, your case)

Manage your subscription for the Freeipa-users mailing list:
Go to for more info on the project

Reply via email to