On 02/28/2017 07:52 PM, lejeczek wrote:


On 28/02/17 09:45, Petr Vobornik wrote:
On 02/26/2017 11:35 AM, lejeczek wrote:
hi everyone

I first time see:

unable to decode: {replica 60} 586eaffd000a003c0000 586eaffd000a003c0000
Replica Update Vectors:
....

on all four servers. What would be a correct troubleshooting and fixing this
problem?
many thanks,
L.




Hello,

what is the version and OS of your IPA servers and DS?

 $ rpm -q ipa-server freeipa-server 389-ds-base
well I run a Centos 7.x and
~]$ rpm -q ipa-server freeipa-server 389-ds-base
ipa-server-4.4.0-14.el7.centos.4.x86_64
package freeipa-server is not installed
389-ds-base-1.3.5.10-15.el7_3.x86_64

I searched the net and archives but failed to find anything flagged as "solved".
if you expect help, you should provide a bit more information than the snippet of an error message. As Petr pointed out this looks like a problem of a corrupted RUV, but we also haven't seen these for a long time. Could you describe your deployment, what changed recently (addigng/removing replicas, crashes,.... )
A mapping of servers and replica Ids, to which server does "60" refer?
Check the ruvs for all suffixes on all servers.
Try cleaning the RUV, if IPA command does not work do it by ldapmodify

There have been many discussions on this topic in this mailing list, look for "cleanallruv", "haunted servers",..

Ludwig



Similar issues happened last year, you can search the archives for "unable to decode" but a 389-ds fix improved the situation. So if you have older version then maybe update and then manual cleanup of RUVs might help.





--
Red Hat GmbH, http://www.de.redhat.com/, Registered seat: Grasbrunn,
Commercial register: Amtsgericht Muenchen, HRB 153243,
Managing Directors: Charles Cachera, Michael Cunningham, Michael O'Neill, Eric 
Shander

-- 
Manage your subscription for the Freeipa-users mailing list:
https://www.redhat.com/mailman/listinfo/freeipa-users
Go to http://freeipa.org for more info on the project

Reply via email to