I just thought I'd give a heads up about some of the code
cleanup/auditing I'm doing for 0.3.0.
1) Some of the fiid templates are inconsistent with each other. I've
been personally hit by bugs b/c some templates used "user_name" as a
field name while others used "username". I've also seen "num" vs.
"number", and "addr" vs. "address". So a number of templates/fields may
be changing soon as I try to create consistency through the library.
Most of the time, I simply rename fields to exactly what is in the spec.
2) Likewise for function names and template names. For example,
"fill_hdr_session" vs. "fill_lan_msg_hdr". "fill_hdr_session" is
now "fill_lan_session_hdr". ipmi-sessions.[ch] are now gone too, with
code moved into ipmi-lan files.
3) Code ordering. This is just me being anal. But I'm making sure
templates, functions, etc. are ordered in the files correctly. It makes
it easier for reading the code along with the spec.
4) Of course there is duplicate code, unused code, random crapola that
I'm cleaning up / removing along the way.
High Performance Systems Division
Lawrence Livermore National Laboratory
Freeipmi-devel mailing list