Hi,

Thanks for your help.
On one of my system
# dmidecode
Handle 0x0027
        DMI type 38, 18 bytes.
        IPMI Device Information
                Interface Type: Unknown
                Specification Version: 0.0
                I2C Slave Address: 0x00
                NV Storage Device Address: 0
                Base Address: 0x0000000000000000 (Memory-mapped)
                Register Spacing: Successive Byte Boundaries
                Interrupt Polarity: Active Low
                Interrupt Trigger Mode: Edge

ie i2c slave address is 0x0 but ipmi-locate is not showing this 0x0 address

su-2.04# ./ipmi-locate          [This is from i just worked on freeipmi 0.5 
beta]
Probing KCS device using DMIDECODE... FAILED
Probing SMIC device using DMIDECODE... FAILED
Probing BT device using DMIDECODE... FAILED
Probing SSIF device using DMIDECODE... FAILED
Probing KCS device using SMBIOS... FAILED
Probing SMIC device using SMBIOS... FAILED
Probing BT device using SMBIOS... FAILED
Probing SSIF device using SMBIOS... FAILED
Probing KCS device using ACPI... FAILED
Probing SMIC device using ACPI... FAILED
Probing BT device using ACPI... FAILED
Probing SSIF device using ACPI... FAILED
Probing KCS device using PCI... FAILED
Probing SMIC device using PCI... FAILED
Probing BT device using PCI... FAILED
Probing SSIF device using PCI... FAILED

KCS device default values:
IPMI Version: 1.5
IPMI locate driver: DEFAULT
IPMI interface: KCS
BMC driver device:
BMC I/O base address: CA2
Register spacing: 1

SMIC device default values:
IPMI Version: 1.5
IPMI locate driver: DEFAULT
IPMI interface: SMIC
BMC driver device:
BMC I/O base address: CA9
Register spacing: 1

BT device default values:

SSIF device default values:
IPMI Version: 1.5
IPMI locate driver: DEFAULT
IPMI interface: SSIF
BMC driver device: /dev/i2c-0
BMC SMBUS slave address: 42
Register spacing: 1

What does it mean?
Is there something wrong with this box?
hw.smbios.system.manufacturer: Supermicro
hw.smbios.system.product_name: X6DH8

Whereas on Intel box ipmi-locate is showing slave address same as dmidecode is 
showing. If you need any 4.x testing, I can provide you the tool output.

Thanks
Sharad Chandra
--
* Sharad Chandra <[EMAIL PROTECTED]> [21.11.2007 12:24]:
> Hi,
>
>       A quick question,
> What is the latest freeipmi package that i can install on freebsd 4.x,
> I had freeipmi -0.2 beta version on one of my system but ipmi-locate
> doesn't show probing devices using dmidecode any where.

The latest version of FreeIPMI, that I was able to run on 4.x was 0.2.3.
You can get port tarball here:

http://www.freebsd.org/cgi/cvsweb.cgi/ports/sysutils/freeipmi/freeipmi.tar.gz
?only_with_tag=RELEASE_6_2_0;tarball=1

Does something about IPMI show up when You run dmidecode utility
(ports/sysutils/dmidecode)? Try "dmidecode | grep -i -A10 ipmi" as root.

> I tried to compile freeipmi-0.5 beta0 with its dependency taken from
> RELEASE_4_EOL branch, but at last i found,

E-mail, forwarded by Al, says it all. To summarize: to run fresh
FreeIPMI on FBSD 4.x one would need to workaround absence of stdint.h
and of getpw*_r() functions at least. Unfortunately, I don't even have
4.x system at hand, so can't try.


_______________________________________________
Freeipmi-devel mailing list
Freeipmi-devel@gnu.org
http://lists.gnu.org/mailman/listinfo/freeipmi-devel

Reply via email to