Retry, first send failed.

-----Original Message-----
From: Cress, Andrew R [mailto:[EMAIL PROTECTED] 
Sent: Friday, December 05, 2008 8:43 AM
To: Albert Chu; Bryan Henderson; Andy Cress;
Subject: RE: [bug #24300] ipmiconsole cannot connect to various Intel servers


This was the first time I had tried ipmiconsole, so I don't know if it worked 
before or what changed.  

For an example of what is different with Intel boards, you can view the source 
to ipmitool or ipmiutil under the 'lanplus' protocol.  It boils down to some 
different assumptions about defaults or special conditions.
In ipmitool, the syntax requires specifying "-o intelplus", but ipmiutil 
detects the manufacturer/product id first and doesn't need those options.  

>From ipmiutil:
lib/lanplus/lanplus.c:is_sol_partial_ack() has an intelplus special case, which 
probably should apply to all other boards too (?)
lib/lanplus/lanplus.c:ipmi_lanplus_open_session() has an intelplus condition 
for privilege defaults
lib/lanplus/lanplus_crypt.c:lanplus_rakp4_hmac_matches() has two intelplus cases
lib/lanplus/lanplus_crypt.c:lanplus_generate_rakp3_authcode() has an intelplus 
case for privilege defaults

That's all that is different.


-----Original Message-----
From: Albert Chu [mailto:[EMAIL PROTECTED] 
Sent: Thursday, December 04, 2008 5:47 PM
To: Albert Chu; Bryan Henderson; Andy Cress;
Subject: [bug #24300] ipmiconsole cannot connect to various Intel servers

Follow-up Comment #2, bug #24300 (project freeipmi):

Sorry I didn't see these posts earlier.  Hopefully I've fixed the config on
Savannah so that bugs actually send out e-mails to the mailing list.

I implemented the Intel workarounds a long time ago, but no longer have an
Intel motherboard.  So I've been forward porting the patches since then and
praying they still work and I didn't mess anything up along the way.  I guess
something is messed up or there is something new to workaround.

Hopefully I can find an Intel mobo to try and fix this on.  I'm going through
the code right now visually and can't see a workaround issue.


P.S.  Bryan, I can see how the wording of the manpage was misinterpreted to
make you think "I note the manual mentions this can happen with
--workaround=intel20, but it doesn't mention anything to do about it. ".  I'm
going to fix up the manpage to instead say:

There are a number of Intel IPMI 2.0 bugs.  These problems may cause
"username invalid", "password invalid", or "k_g invalid" errors to occur. 
They can be worked around by specifying the "intel20" workaround.


Reply to this item at:


  Message sent via/by Savannah

Freeipmi-devel mailing list

Reply via email to