Hi Devon,

Could you try some of the workaround flags in ipmipower.  Most notably the "intel20" workaround flag, but perhaps the "opensesspriv" one as well as its been seen on some intel motherboards too.

Another thing to try would be to try using the "admin" privilege instead of the "operator" one (which ipmipower defaults to).  I've seen some motherboards simply ignore the privilege that the user specifies and just assume "admin" is used by the user all of the time (ipmitool defaults to "admin").

If that doesn't work, could you send me the full --debug output. intel has had a rash of authentication corner cases, so hopefully this is not a new one or one that was previously missed.


On 10/27/22 13:16, Bautista, Devon Thomas via Freeipmi-users wrote:

I have a few Intel M50CYP boards that I can get to work with ipmitool, but not FreeIPMI.

I can successfully run power commands and activate sol via, e.g:

ipmitool -I lanplus -U admin -P $PWORD -H host-bmc sol activate

However, when I run `ipmipower' or `ipmiconsole', I get "BMC busy". When I turn on debugging, e.g., and try to stat the power with `ipmipower', I get an exit code of 0x1 which, according to Table 13 of the IPMI Specification, means "Insufficient resources to create a session". This is strange, considering I can use ipmitool to start a sol session just fine.

The output of the above ipmipower example (trimmed) is as follows:

$ ipmipower -D LAN_2_0 -h host-bmc -u admin -p $PWORD
ipmipower> debug
debugging is now on
ipmipower> stat
host-bmc: =====================================================
host-bmc: IPMI 2.0 Open Session Response
host-bmc: =====================================================
host-bmc: RMCP Header:
host-bmc: ------------
host-bmc: [               6h] = version[ 8b]
host-bmc: [               0h] = reserved[ 8b]
host-bmc: [              FFh] = sequence_number[ 8b]
host-bmc: [               7h] = message_class.class[ 5b]
host-bmc: [               0h] = message_class.reserved[ 2b]
host-bmc: [               0h] = message_class.ack[ 1b]
host-bmc: IPMI RMCPPLUS Session Header:
host-bmc: -----------------------------
host-bmc: [               6h] = authentication_type[ 4b]
host-bmc: [               0h] = reserved1[ 4b]
host-bmc: [              11h] = payload_type[ 6b]
host-bmc: [               0h] = payload_type.authenticated[ 1b]
host-bmc: [               0h] = payload_type.encrypted[ 1b]
host-bmc: [               0h] = session_id[32b]
host-bmc: [               0h] = session_sequence_number[32b]
host-bmc: [               8h] = ipmi_payload_len[16b]
host-bmc: IPMI RMCPPLUS Payload:
host-bmc: ----------------------
host-bmc: [  BYTE ARRAY ... ] = payload_data[ 8B]
host-bmc: [ CAh 01h 00h 00h 43h 43h D7h BEh ]
host-bmc: IPMI Command Data:
host-bmc: ------------------
host-bmc: [              CAh] = message_tag[ 8b]
host-bmc: [               1h] = rmcpplus_status_code[ 8b]
host-bmc: [               0h] = maximum_privilege_level[ 4b]
host-bmc: [               0h] = reserved1[ 4b]
host-bmc: [               0h] = reserved2[ 8b]
host-bmc: [        BED74343h] = remote_console_session_id[32b]
(ipmipower_check.c, ipmipower_check_rmcpplus_status_code, 713): host = host-bmc; p = 4; rmcpplus_status_code failed: 1h
host-bmc: BMC busy

I have updated the board firmware and BMC firmware to the latest version provided by Intel with the same result. Is there any further troubleshooting I could perform? Let me know if you would like the full debug output.


Freeipmi-users mailing list

Albert Chu
Livermore Computing
Lawrence Livermore National Laboratory

Freeipmi-users mailing list

Reply via email to