Thanks again for the reply.
Yes it was a mistake on my behalf no1 elses (Im dsylexic and misread
the suse as fedora).

Thanks for catching me on that,

Keep up the good work guys.

On 4/19/07, [EMAIL PROTECTED] <[EMAIL PROTECTED]> wrote:
> Hi,
>
> > Notes:
> > * The wiki glosses over a little and gives u an incorrect dir
> > * the spec file expects 1.1.5 tar.gz
>
> yes, that has already been noted. simply edit the spec file
> to use the correct value.
>
> > # tar zxvf /root/Desktop/freeradius-1.1.6.tar.gz
> > # cp /root/Desktop/freeradius-1.1.6.tar.gz
> > /usr/src/redhat/SOURCES/freeradius-1.1.5.tar.gz
> > # cp freeradius-1.1.6/suse/freeradius.spec  /usr/src/redhat/SPECS/
> > # rpmbuild -ba /usr/src/redhat/SPECS/freeradius.spec
>
> just confirm that you are running SUSE or RedHat/Fedora/CentOS ?
>
> > [EMAIL PROTECTED] src]# rpmbuild -ba /usr/src/redhat/SPECS/freeradius.spec
> > sh: apxs2-prefork: command not found
> > sh: apxs2-prefork: command not found
> > sh: apxs2-prefork: command not found
>
> okay. no apache devel tools installed.
>
> > error: Failed build dependencies:
> >         apache2-devel is needed by freeradius-1.1.5-0.generic.i386
> >         db-devel is needed by freeradius-1.1.5-0.generic.i386
> >         gettext-devel is needed by freeradius-1.1.5-0.generic.i386
> >         mysql-devel is needed by freeradius-1.1.5-0.generic.i386
> >         net-snmp-devel is needed by freeradius-1.1.5-0.generic.i386
> >         openldap2-devel is needed by freeradius-1.1.5-0.generic.i386
> >         postgresql-devel is needed by freeradius-1.1.5-0.generic.i386
> >         unixODBC-devel is needed by freeradius-1.1.5-0.generic.i386
>
> yep. it'll need all of these - IF you want a fully specced FreeRADIUS
> install. you can edit the SPEC file if you really want/need
> to have less features - simply edit the ./configure command etc and
> remove the dependencies that match those changes.
>
> > now checking yum and smart --gui I do not see apache2-devel for starters.
>
> correct distro for the spec file?
> how did you check with yum?
>
> > So for the mean time I am back to compiling as rpm's are causing the
> > issues they are famous for. If some1 has some tips on resolving
> > dependancies I will be intrested. But I do not see what it needs
> > apache2 headers anyway.
>
> that'd be for the lovely FreeRADIUS apache authentication module 
> mod_auth_radius most likely
>
> alan
> -
> List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html
>
- 
List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html

Reply via email to