External Email - Use Caution        

Hello Tristan,
Please check to see that what is listed in the makefile.wiki under the section 
for Ubuntu is installed on your machine.   I would also try building with 
the instructions in the makefile if you have not already done so; that works on 
my Ubuntu 18.04 system, although I am not running the server distribution, 
e.g., type “make -f makefile.wiki help”.   The makefile based build will 
also save logs for the cmake command, build and install pass, so you could send 
me those directly - look for ./freesurfer/{cmake.log, make.log, install.log}

- R.

On Sep 10, 2019, at 13:52, TRISTAN J PAUTSCH <tpaut...@wisc.edu> 
wrote:        External Email - Use 
Caution        Thank you so much again 
for the detailed reply. I attempted your suggestion, following the 
instructions from the wiki to a T and compiled everything from scratch, and I 
still get the same PETSC error from my first post. To be thorough, I again 
tested on multiple machines, experiencing the same error on each.I also 
realized I've never posted the specs of the system on which I've been 
attempting all of this, so in case it's relevant to anyone else, here they 
are:OS: Ubuntu 18.04 ServerCPU: 4x Xeon Platinum 8164RAM: 512GB DDR4 ECC 
<tpaut...@wisc.edu>Sent: Thursday, August 29, 2019 10:27 
AMTo: fsbuild 
<fsbu...@contbay.com>Cc: freesurfer@nmr.mgh.harvard.edu <freesurfer@nmr.mgh.harvard.edu>Subject: Re:
 [Freesurfer] freeview crash -- petsc error when opening volume Thank you 
for the reply, I will try this when time permits!TristanFrom: fsbuild 
<fsbu...@contbay.com>Sent: Tuesday, August 27, 2019 4:25 
<tpaut...@wisc.edu>Cc: freesurfer@nmr.mgh.harvard.edu 
<freesurfer@nmr.mgh.harvard.edu>Subject: Re: [Freesurfer] freeview 
crash -- petsc error when opening volume Hello Tristan,Please try 
rebuilding the dev branch on your Ubuntu 18 machine using the makefile listed 
from the wiki, (wiki 
page, https://surfer.nmr.mgh.harvard.edu/fswiki/CMake) where the 
download link to makefile 
is https://drive.google.com/file/d/1IMEWQty_7zjsglbErQOlu_KpXb8Lmgmv/view?usp=sharingIt
 should go in the same subdirectory that contains the ./freesurfer treeThere 
are some comments in there which recommend the following be installed for 
Ubuntu, so please check these are installed before building,    
  # sudo apt-get install build-essential      # 
sudo apt-get install libgl1-mesa-dev freeglut3-dev mesa-common-dev    
  # sudo apt-get install libblas-dev liblapack-dev    
  # sudo apt-get install ocl-icd-opencl-dev    
  # sudo apt-get install libxmu-dev libxi-dev    
  # sudo apt-get install libopencv-dev     
  # Ubuntu 16: sudo apt-get install gcc-4.9 g++-4.9 
gfortran-4.9      # Ubuntu 18: sudo apt-get install gcc-4.8 
g++-4.8 gfortran-4.8 <----      # sudo apt-get install 
xorg xorg-dev libx11-dev      # sudo apt-get install tcl 
tcl-dev tk tk-dev      # sudo apt-get install qt5-default 
qtcreator      # sudo apt-get install 
libqt5x11extras5-dev      # sudo apt-get install 
git-annex       # sudo apt-get install python3-devI’ve 
attached an archive containing that makefile along with the cmake output/build 
logs from my Ubuntu 18.04 machine so you can see what it looks like for me, 
see cmake_make_install_ubuntu18.tgzI’ve run all the freeview tutorial 
commands using the 6.0.0 release on my Ubuntu 18.04 machine, but have not been 
able to reproduce a petsc error so far.- R.On Aug 27, 2019, at 11:27, TRISTAN J 
PAUTSCH <tpaut...@wisc.edu> 
wrote:        External Email - Use 
Caution        Some final bits of 
troubleshooting information for future readers, since I'm assuming this issue 
will now get lost in the sauce...I'll probably try compiling everything from 
scratch at some point, but my hopes aren't particularly highI manually compiled 
the missing libs to get the CentOS7 version of FS-dev freeview running on 
Ubuntu 18, and ultimately the same errors occur. As well, I replicated this 
behavior on a separate Ubuntu 18 machine in the environment, this time using a 
different lab's T1/brainmask/surface files. It would definitely seem like there 
is some sort of hard incompatibility with newer versions of freeview and 
loading surface files on top of volumes in Ubuntu 18. For what it's worth, 
it's not evident that any other part of FS has an issue; all CLI tools seem to 
work just fine.TristanFrom: TRISTAN J PAUTSCH 
<tpaut...@wisc.edu>Sent: Friday, August 23, 2019 11:38 
AMTo: Freesurfer support list 
<freesurfer@nmr.mgh.harvard.edu>Subject: Re: [Freesurfer] freeview 
crash -- petsc error when opening volume Good morning Ruopeng, thank you 
for your continued assistance!Unfortunately, I get the same error using the 
CentOS6 dev version.. I tried the CentOS7 dev version, however this led to a 
series of library errors, the majority of which are unsolvable on Ubuntu 18 
without individually compiling each necessary library (sym-linking newer 
libraries does not work).I wanted to ensure I provide the most details 
possible, so I also installed FS 5.3.0 and tested the files...interestingly, 
they opened just fine, no errors at all.This leads me to believe there is some 
strange incompatibility between Ubuntu 18 and the 6.x/dev version of FS (at 
least when it comes to surface files), specifically related to PETSC. Is there 
anything else I can do to help 
troubleshoot?TristanFrom: freesurfer-boun...@nmr.mgh.harvard.edu 
<freesurfer-boun...@nmr.mgh.harvard.edu> on behalf of Ruopeng Wang 
<rpw...@nmr.mgh.harvard.edu>Sent: Thursday, August 22, 2019 5:00 
PMTo: Freesurfer support list 
<freesurfer@nmr.mgh.harvard.edu>Subject: Re: [Freesurfer] freeview 
crash -- petsc error when opening volume Hi Tristan,Thanks for the files. 
I have no problem loading them with the latest dev build and stable 6..0 build. 
I do not have an Ubuntu system, though. If I’m not mistaken you use dev 
version of freeview binary along with stable 6.0 FS binary. Is that correct? Is 
there any chance you can try installing the whole FS dev package?RuopengOn Aug 
22, 2019, at 12:20 PM, TRISTAN J PAUTSCH <tpaut...@wisc.edu> 
wrote:        External Email - Use 
Caution        Ruopeng,I've uploaded 
the files to the FTP drop (transfer/incoming/freesurfer_data.tar.gz). The 
command my user is running against these files is:freeview -v brainmask.mgz 
T1.mgz -f lh.white:edgecolor=yellow lh.pial:edgecolor=magenta 
rh.white:edgecolor=yellow rh.pial:edgecolor=magentaWe can also replicate the 
error by opening freeview and opening all the above files sequentially through 
the GUI.Thank 
you!TristanFrom: freesurfer-boun...@nmr.mgh.harvard.edu <freesurfer-boun...@nmr.mgh.harvard.edu>
 on behalf of Ruopeng Wang 
<rpw...@nmr.mgh.harvard.edu>Sent: Thursday, August 22, 2019 8:16 
AMTo: Freesurfer support list 
<freesurfer@nmr.mgh.harvard.edu>Subject: Re: [Freesurfer] freeview 
crash -- petsc error when opening volume Hi Tristan,Would it be possible 
to send us the files and the command-line you run? Best,RuopengOn Aug 21, 
2019, at 12:18 PM, TRISTAN J PAUTSCH <tpaut...@wisc.edu> 
wrote:        External Email - Use 
Caution        Adding more details 
provided by my user:The crash only happens when loading surface files, either 
via the -f flag from the CLI or directly through the GUI. Could this be an 
issue with the surface files or the manner in which they are 
created?From: freesurfer-boun...@nmr.mgh.harvard.edu <freesurfer-boun...@nmr.mgh.harvard..edu>
 on behalf of TRISTAN J PAUTSCH 
<freesurfer-boun...@nmr.mgh.harvard.edu>Sent: Tuesday, August 20, 
2019 2:35 
PMTo: freesurfer@nmr.mgh.harvard.edu <freesurfer@nmr.mgh.harvard.edu>Subject: [Freesurfer]
 freeview crash -- petsc error when opening 
volume         External Email - 
Use Caution        Greetings all, I'll 
try to keep this succinct. I'm attempting to deploy FreeSurfer on Ubuntu 
18.04 servers here at the lab. I used the stable 6.0/CentOS 6 download, in 
addition to the dev version of freeview per the .../fswiki/UpdateFreeview 
instructions. All dependencies have ostensibly been satisfied, all libs from 
'ldd freeview.bin' installed. Freeview launches fine and stays open when 
launched alone, however attempting to open a volume (either through the GUI or 
directly via the CLI) causes a crash and the following error about 5-8 seconds 
after launching (brain images begin to populate, then crash):---[0]PETSC ERROR: 
 ERROR: Caught signal number 11 SEGV: Segmentation Violation, probably memory 
access out of range[0]PETSC ERROR: Try option -start_in_debugger or 
-on_error_attach_debugger[0]PETSC ERROR: or 
see http://www.mcs.anl.gov/petsc/petsc-as/documentation/troubleshooting.html#Signal[0]PETSC ERROR:
 or try http://valgrind.org on linux or man libgmalloc on Apple to 
find memory corruption errors[0]PETSC ERROR: configure using 
--with-debugging=yes, recompile, link, and run [0]PETSC ERROR: to get more 
information on the crash.[0]PETSC ERROR: --------------------- Error Message 
------------------------------------[0]PETSC ERROR: Signal received![0]PETSC 
 ERROR: Petsc Release Version 2.3.3, Patch 13, Thu May 15 17:29:26 CDT 2008 HG 
revision: 4466c6289a0922df26e20626fd4a0b4dd03c8124[0]PETSC ERROR: See 
docs/changes/index.html for recent updates.[0]PETSC ERROR: See docs/faq.html 
for hints about trouble shooting.[0]PETSC ERROR: See docs/index.html for manual 
pages.[0]PETSC ERROR: 
 ERROR: Unknown Name on a linux-gnu named xxxxxxx by xxxxxxx Tue Aug 20 
13:44:15 2019[0]PETSC ERROR: Libraries linked from 
 ERROR: Configure run at Tue Aug 10 15:01:59 2010[0]PETSC ERROR: Configure 
options --with-debugging=no --with-cc=gcc --with-fc=g77 
--download-f-blas-lapack=0 --download-mpich=1 --with-mpi=1 --with-x=0 
--with-gnu-copyright-code=0 --with-shared=0 COPTFLAGS=-O3 CXXOPTFLAGS=-O3 
 ERROR: User provided function() line 0 in unknown directory unknown 
file[unset]: aborting job:application called MPI_Abort(MPI_COMM_WORLD, 59) - 
process 0Segmentation fault (core dumped)---I've seen a number of other posts 
on the mailing list about this, but all of them I could find either 
end abruptly without a solution or with an unanswered request for more 
info. Happy to provide any additional information or anything that may aid 
in the resolution of this issue. Thanks 
everyone,~T_______________________________________________Freesurfer mailing 
Freesurfer mailing list

Reply via email to