> toString(x : DoubleFloat) : String == > unparse(convert(x)@InputForm)
> Remark: According to Axiom philosophy this function should be > called 'coerce' and DoubleFloat should have CoercibleTo(String). Yes. > But I do not want to try what crazy things interpreter will > do with such coercion... Very much agreed. But what about "convert"? That should be the standard name of such a function that the interpreter should not consider in automatic coercions. Also "string: DoubleFloat -> String" would be an option, but I'd rather vote for "convert". Ralf -- You received this message because you are subscribed to the Google Groups "FriCAS - computer algebra system" group. To post to this group, send email to [email protected]. To unsubscribe from this group, send email to [email protected]. For more options, visit this group at http://groups.google.com/group/fricas-devel?hl=en.
