$ ./scripts/composer_wrapper.php install --no-dev
> LibreNMS\ComposerHelper::preInstall
Loading composer repositories with package information
Installing dependencies from lock file
Nothing to install or update
Generating autoload files
> LibreNMS\ComposerHelper::postInstall
> Illuminate\Foundation\ComposerScripts::postInstall
> php artisan optimize
Generating optimized class loader
The compiled services file has been removed.

$ composer install --no-dev
> LibreNMS\ComposerHelper::preInstall
Loading composer repositories with package information
Installing dependencies from lock file
Nothing to install or update
Generating autoload files
> LibreNMS\ComposerHelper::postInstall
> Illuminate\Foundation\ComposerScripts::postInstall
> php artisan optimize
Generating optimized class loader
The compiled services file has been removed.

-> pas mieux
le pire c’est que je n’ai aucun problème pour écrire dans les répertoires 
indiqués avec le user librenms
Ca pourrait donc être un problème de SELinux, mais comme il n’est pas activé…


On 11 mai 2018 10:58 +0200, Armel Chargé - frekences <ar...@frekences.com>, 
wrote:
> Un petit composer wrapper pour la forme :
>
> ./scripts/composer_wrapper.php install --no-dev
>
> Puis  :
>
> composer install --no-dev
>
> De: David Ponzone <david.ponz...@gmail.com>
> Répondre: David Ponzone <david.ponz...@gmail.com>
> Date: 11 mai 2018 at 10:56:00
> À: Frnog-tech <frnog-t...@frnog.org>, Armel Chargé - frekences 
> <ar...@frekences.com>
> Sujet:  Re: [FRnOG] [TECH] LilbreNMS HS
>
> > Yep.
> > Aucun problème.
> >
> >
> > On 11 mai 2018 10:51 +0200, Armel Chargé - frekences <ar...@frekences.com>, 
> > wrote:
> > > Tu as fait un ./validate.php  ?
> > >
> > >
> > >
> > >
> > >
> > > De: David Ponzone <david.ponz...@gmail.com>
> > > Répondre: David Ponzone <david.ponz...@gmail.com>
> > > Date: 11 mai 2018 at 10:45:17
> > > À: Frnog-tech <frnog-t...@frnog.org>, Armel Chargé - frekences 
> > > <ar...@frekences.com>
> > > Sujet:  Re: [FRnOG] [TECH] LilbreNMS HS
> > >
> > > > Après un problème avec une lib PHP manquante (mbstring), j’ai:
> > > >
> > > > Error: bootstrap/cache, storage, storage/framework/sessions, 
> > > > storage/framework/views,
> > > > storage/framework/cache not writable! Run these commands as root on 
> > > > your LibreNMS server to fix:
> > > >
> > > > chown -R librenms:librenms /opt/librenms/bootstrap/cache 
> > > > /opt/librenms/storage /opt/librenms/storage/framework/sessions 
> > > > /opt/librenms/storage/framework/views 
> > > > /opt/librenms/storage/framework/cache
> > > >
> > > > setfacl -R -m g::rwx /opt/librenms/bootstrap/cache 
> > > > /opt/librenms/storage /opt/librenms/storage/framework/sessions 
> > > > /opt/librenms/storage/framework/views 
> > > > /opt/librenms/storage/framework/cache
> > > >
> > > > setfacl -d -m g::rwx /opt/librenms/bootstrap/cache 
> > > > /opt/librenms/storage /opt/librenms/storage/framework/sessions 
> > > > /opt/librenms/storage/framework/views 
> > > > /opt/librenms/storage/framework/cache
> > > >
> > > > If using SELinux you may also need:
> > > >
> > > > semanage fcontext -a -t httpd_sys_content_t 
> > > > '/opt/librenms/bootstrap/cache(/.*)?'
> > > >
> > > > semanage fcontext -a -t httpd_sys_rw_content_t 
> > > > '/opt/librenms/bootstrap/cache(/.*)?'
> > > >
> > > > restorecon -RFvv /opt/librenms/bootstrap/cache
> > > >
> > > > semanage fcontext -a -t httpd_sys_content_t 
> > > > '/opt/librenms/storage(/.*)?'
> > > >
> > > > semanage fcontext -a -t httpd_sys_rw_content_t 
> > > > '/opt/librenms/storage(/.*)?'
> > > >
> > > > restorecon -RFvv /opt/librenms/storage
> > > >
> > > > semanage fcontext -a -t httpd_sys_content_t 
> > > > '/opt/librenms/storage/framework/sessions(/.*)?'
> > > >
> > > > semanage fcontext -a -t httpd_sys_rw_content_t 
> > > > '/opt/librenms/storage/framework/sessions(/.*)?'
> > > >
> > > > restorecon -RFvv /opt/librenms/storage/framework/sessions
> > > >
> > > > semanage fcontext -a -t httpd_sys_content_t 
> > > > '/opt/librenms/storage/framework/views(/.*)?'
> > > >
> > > > semanage fcontext -a -t httpd_sys_rw_content_t 
> > > > '/opt/librenms/storage/framework/views(/.*)?'
> > > >
> > > > restorecon -RFvv /opt/librenms/storage/framework/views
> > > >
> > > > semanage fcontext -a -t httpd_sys_content_t 
> > > > '/opt/librenms/storage/framework/cache(/.*)?'
> > > >
> > > > semanage fcontext -a -t httpd_sys_rw_content_t 
> > > > '/opt/librenms/storage/framework/cache(/.*)?'
> > > >
> > > > restorecon -RFvv /opt/librenms/storage/framework/cache
> > > >
> > > >
> > > > J’ai beau faire le chown (pas le reste, j’ai pas selinux installé), le 
> > > > message persiste.
> > > > apt-get upgrade fait
> > > > reboot fait
> > > > (debian 9.4)
> > > >
> > > >
> > > > On 11 mai 2018 10:43 +0200, Armel Chargé - frekences 
> > > > <ar...@frekences.com>, wrote:
> > > > > Salut,
> > > > >
> > > > > Quels soucis as tu rencontré ?
> > > > >
> > > > > J’ai plusieurs instances UP sans défauts particulier malgré le 
> > > > > daily.sh qui a tourné.
> > > > >
> > > > > Armel
> > > > >
> > > > >
> > > > > De: David Ponzone <david.ponz...@gmail.com>
> > > > > Répondre: David Ponzone <david.ponz...@gmail.com>
> > > > > Date: 11 mai 2018 at 10:36:40
> > > > > À: Frnog-tech <frnog-t...@frnog.org>
> > > > > Sujet:  [FRnOG] [TECH] LilbreNMS HS
> > > > >
> > > > > > Je suis le seul à avoir LibreNMS HS ?
> > > > > > A priori y a pas mal de monde concerné…
> > > > > >
> > > > > >
> > > > > > ---------------------------
> > > > > > Liste de diffusion du FRnOG
> > > > > > http://www.frnog.org/

---------------------------
Liste de diffusion du FRnOG
http://www.frnog.org/

Répondre à