@samuel
C'est un soucis de copier/coller dans la réalité l'adressage est correcte.
Le contenu du dhcpd.conf est ci-dessous.

@fabrice
L'option 66 c'est semble t'il le next-server mais j'avoue que je n'arrive
pas à trouver une doc identique sur le sujet...

Après vérification, il s'agit bien de next-server, j'ai tenté aussi avec

   option bootfile-na1me "bootx64.efi";
   option tftp-server-name "192.168.0.2";

Même résultat

Le dhcpd.conf :

allow booting;
allow bootp;

default-lease-time 86400;
max-lease-time 604800;

authoritative;

subnet 192.168.0.0 netmask 255.255.0.0 {
   range 192.168.0.10 192.168.0.200;
   next-server 192.168.0.2;
   filename "bootx64.efi";
   option subnet-mask 255.255.255.0;
   option broadcast-address 192.168.0.255;
}

Sachant que :

[root@ip208 ~]# ip addr
2: ens192: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast
state UP group default qlen 1000
    link/ether 00:50:56:02:6a:b0 brd ff:ff:ff:ff:ff:ff
    inet xx.xx.xx.xx/32 brd xx.xx.xx.xx scope global noprefixroute ens192
3: ens224: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast
state UP group default qlen 1000
    link/ether 00:0c:29:ee:42:ca brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.2/32 brd 192.168.0.2 scope global noprefixroute ens224


[root@ip208 ~]# firewall-cmd --list-services
ssh dhcp tftp-client


Le 11 juin 2018 à 18:44, <samuel.gaiani-porq...@infiniteconnection.fr> a
écrit :

> Bonjour Aliza,
>
> Tu es sur que tu n'as pas un problème d'adressage quelque part? Ta VM ne
> semble pas prendre d'ip dans le range de ta conf sur le serveur dhcp.
> Peux tu nous faire un extract de  /etc/dhcpd.conf ?
>
> As tu également redémarrer ton serveur dhcp pour tes changements soient
> pris en compte? (service isc-dhcp-server restart )
>
>
> Cordialement,
>
>
>
>
> Le 11.06.2018 16:47, Aliza Amalice a écrit :
>
>> Salut à tous,
>>
>> Je tente vainement depuis plusieurs jours de mettre en place du PXE sur
>> mon
>> archi ESXi pour installer l'OS de mes VM.
>>
>> J'ai une VM qui fait office de DHCP / TFTP et qui possède une patte public
>> (c'est dans une infra OVH) et une patte privée.
>>
>> Dés lors que je place une VM à installer dans le réseau privée j'obtiens
>> bien une adresse mais j'ai systématiquement un ARP timeout suivi d'un TFTP
>> cannot connection.
>>
>> J'ai désactivé le firewall, vérifier les options du DHCP mais rien n'y
>> fait.
>>
>> Il y a en a un de vous qui voit un truc qui cloche ??
>>
>> Aliza
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>> La configuration du DHCP est ultra simple :
>>
>> allow booting;
>> allow bootp;
>>
>> subnet 10.0.0.0 netmask 255.255.255.0 {
>>     range 10.0.0.100 10.0.0.200;
>>     next-server 10.0.0.10;
>>     filename "bootx64.efi";
>> }
>>
>>
>> Si je regarde ce qui est renvoyé au boot d'une VM, j'obtiens bien une IP
>> sur le serveur DHCP :
>>
>> 16:38:03.666018 IP (tos 0x10, ttl 128, id 0, offset 0, flags [none], proto
>> UDP (17), length 328)
>>     ip208.ip-51-68-29.eu.bootps > 255.255.255.255.bootpc: [udp sum ok]
>> BOOTP/DHCP, Reply, length 300, xid 0x2a7e4a00, secs 4, Flags [Broadcast]
>> (0x8000)
>>           Your-IP 192.168.0.11
>>           Server-IP ip208.ip-xx-xx-xx.eu
>>           Client-Ethernet-Address 00:0c:29:7e:4a:00 (oui Unknown)
>>           file "bootx64.efi"[|bootp]
>>
>>
>> Suivi de :
>>
>> 16:42:24.828072 ARP, Ethernet (len 6), IPv4 (len 4), Request who-has
>> ip208.ip-xx-xx-xx.eu tell 192.168.0.11, length 46
>> 16:42:25.006094 ARP, Ethernet (len 6), IPv4 (len 4), Reverse Request
>> who-is
>> 00:0c:29:7e:4a:00 (oui Unknown) tell 00:0c:29:7e:4a:00 (oui Unknown),
>> length 46
>>
>>
>> La VM termine avec :
>>
>> PXE-E11 : ARP timeout
>> PXE-E38 : TFTP cannot open connection
>> PXE-M0F : Exiting PXE ROM
>>
>>
>> J'ai pas de routeur pour le 192.168.0.0/24, pas la possibilité d'en
>> mettre
>> et j'en vois pas l'intérêt....
>>
>> ---------------------------
>> Liste de diffusion du FRnOG
>> http://www.frnog.org/
>>
>

---------------------------
Liste de diffusion du FRnOG
http://www.frnog.org/

Répondre à