Le 10/17/16 à 18:04, Julien Escario a écrit :
Bonsoir,
Un disque d'un zpool est mort (jusque là, rien d'exceptionnel).

J'ai ajouté un disque, rebooté la machine (impossible de faire détecter le
nouveau disque via l'outil de la carte RAID). Un serveur de backup, rien de bien
grave.

Le soucis c'est qu'en rebootant le disque mort est revenu en ligne (je me
demande si ce n'est pas un soucis de backplane d'ailleurs).

J'ai gaiement fait un :
# zpool replace backuppool wwn-0x50014ee208b4df37
/dev/disk/by-id/wwn-0x50014ee0aed608b3
je fait tjs zpool attach ; zpool offline; zpool detach ( pour des motifs oubliés)...

...
Le soucis, c'est qu'il semblerait que ca incrémente tout doucement les valeurs
de READ et CKSUM. J'imagine que ce sont des erreurs lecture et checksum.

Ca ne m'embêterait pas si à chaque fois que c'est incrémenté, le resilvering ne
repartait pas à zéro ...

Du coup, j'ai l'impression que mon resilver ne finira jamais (il tourne depuis
quelques jours déjà).

Une idée sur la façon dont je peux m'en sortir ? C'est un serveur de backup donc
je peux mettre hors ligne quelques heures mais si je perds les données, ça va me
prendre DES PLOMBES à tout remettre, sans compter la période de fonctionnement
sans backup 'sec'.
* déconnecter le disque fautif (physiquement ou logiquement via le controleur) * oux reboot en single user/avant zpool import et invalider le tag zpool sur le disque fautif ( wipefs -a /dev/... ?) cad rendre se disque non reconnu par zfs.

mes 2centimes...




--
A: Yes.
Q: Are you sure?
A: Because it reverses the logical flow of conversation.
Q: Why is top posting annoying in email?

_______________________________________________
Liste de diffusion du FRsAG
http://www.frsag.org/

Répondre à