Git-Url: 
http://git.frugalware.org/gitweb/gitweb.cgi?p=pacman-g2.git;a=commitdiff;h=1df19b123857b9d6da7f6112406470bc0d167723

commit 1df19b123857b9d6da7f6112406470bc0d167723
Author: Michel Hermier <[email protected]>
Date:   Fri Nov 1 08:56:07 2013 +0100

libpacman: Add _pacman_db_write_bool to reduce code duplication in 
_pacman_db_write.

diff --git a/lib/libpacman/be_files.c b/lib/libpacman/be_files.c
index 87aa4e8..3c31fab 100644
--- a/lib/libpacman/be_files.c
+++ b/lib/libpacman/be_files.c
@@ -671,6 +671,14 @@ error:
}

static
+void _pacman_db_write_bool(const char *entry, int value, FILE *stream)
+{
+       if(value != 0) {
+               fprintf(stream, "%%%s%%\n\n", entry);
+       }
+}
+
+static
void _pacman_db_write_string(const char *entry, const char *value, FILE *stream)
{
if(!_pacman_strempty(value)) {
@@ -790,14 +798,8 @@ int _pacman_db_write(pmdb_t *db, pmpkg_t *info, unsigned 
int inforeq)
_pacman_db_write_stringlist("PROVIDES", info->provides, fp);
if(!local) {
_pacman_db_write_stringlist("REPLACES", info->replaces, fp);
-                       if(info->force) {
-                               fprintf(fp, "%%FORCE%%\n"
-                                       "\n");
-                       }
-                       if(info->stick) {
-                               fprintf(fp, "%%STICK%%\n"
-                                       "\n");
-                       }
+                       _pacman_db_write_bool("FORCE", info->force, fp);
+                       _pacman_db_write_bool("STICK", info->stick, fp);
}
fclose(fp);
fp = NULL;
_______________________________________________
Frugalware-git mailing list
[email protected]
http://frugalware.org/mailman/listinfo/frugalware-git

Reply via email to