Git-Url: 
http://git.frugalware.org/gitweb/gitweb.cgi?p=gcc6.git;a=commitdiff;h=cdf643bc8337a4b95ea61473245c0863f379c765

commit cdf643bc8337a4b95ea61473245c0863f379c765
Author: crazy <cr...@frugalware.org>
Date:   Tue Sep 20 16:34:46 2016 +0200

poppler-0.47.0-1-x86_64
* Version bump
* without Qt{4,5} ..

diff --git a/source/xlib/poppler/FrugalBuild b/source/xlib/poppler/FrugalBuild
index 25ecd42..b3c1169 100644
--- a/source/xlib/poppler/FrugalBuild
+++ b/source/xlib/poppler/FrugalBuild
@@ -2,26 +2,26 @@
# Maintainer: crazy <cr...@frugalware.org>

USE_GLIB=${USE_GLIB:-"y"}
-USE_QT4=${USE_QT4:-"y"}
-USE_QT5=${USE_QT5:-"y"}
+USE_QT4=${USE_QT4:-"n"}
+USE_QT5=${USE_QT5:-"n"}

## TODO: figure curl
##       switch to cmake

pkgname=poppler
-pkgver=0.46.0
+pkgver=0.47.0
pkgrel=1
pkgdesc="A PDF rendering library"
url="http://poppler.freedesktop.org/";
-depends=('fontconfig>=2.11.94-3' 'cairo>=1.14.6-2' 'libjpeg>=9a' 
'libpng>=1.6.20'  'openjpeg>=1.5.2' 'libstdc++>=5.3.0-2')
-makedepends=('x11-protos' 'gobject-introspection')
+depends=('fontconfig>=2.12-2' 'cairo>=1.14.6-4' 'libjpeg>=9a-2' 
'libpng>=1.6.25'  'openjpeg>=1.5.2-2' 'libstdc++>=6.2.1-5')
+makedepends=('x11-protos' 'gobject-introspection>=1.50.0')
rodepends=('poppler-data')
groups=('xlib')
archs=('i686' 'x86_64')
up2date="Flasttar $url/releases.html"
source=(http://poppler.freedesktop.org/$pkgname-$pkgver.tar.xz \
01-poppler.conf)
-sha1sums=('210b12c2474d3d3f1bb3db5792fe057e69b945ed' \
+sha1sums=('7889b8acba0c83a3accd60770a658ff08f4d7ec2' \
'a048348d9a8c6d545714350d3ab66dc7028e4b7f')
options+=('scriptlet' 'force')
conflicts=('poppler-qt')
@@ -35,7 +35,7 @@ if Fuse $USE_GLIB; then
subpkgs=("${subpkgs[@]}" 'poppler-glib')
subdescs=("${subdescs[@]}" 'Poppler glib bindings')
subgroups=("${subgroups[@]}" 'xlib')
-       subdepends=("${subdepends[@]}" 'cairo>=1.14.6-2 libffi>=3.2.1 
libpng>=1.6.20 libstdc++>=5.3.0-2')
+       subdepends=("${subdepends[@]}" 'cairo>=1.14.6-4 libffi>=3.2.1-2 
libpng>=1.6.25 libstdc++>=6.2.1-5')
subrodepends=("${subrodepends[@]}" "poppler>=$pkgver")
subarchs=("${subarchs[@]}" 'i686 x86_64')
subreplaces=("${subreplaces[@]}" '')
@@ -45,7 +45,7 @@ fi
subpkgs=("${subpkgs[@]}" 'poppler-pdftools')
subdescs=("${subdescs[@]}" 'Poppler xpdf tools')
subgroups=("${subgroups[@]}" 'xapps')
-subdepends=("${subdepends[@]}" 'lcms2>=2.7-3 cairo>=1.14.6-2 libffi>=3.2.1 
libpng>=1.6.20 libstdc++>=5.3.0-2')
+subdepends=("${subdepends[@]}" 'lcms2>=2.8-2 cairo>=1.14.6-4 libffi>=3.2.1-2 
libpng>=1.6.25 libstdc++>=6.2.1-5')
subrodepends=("${subrodepends[@]}" 'poppler')
subarchs=("${subarchs[@]}" 'i686 x86_64')
subreplaces=("${subreplaces[@]}" 'xpdf')
_______________________________________________
Frugalware-git mailing list
Frugalware-git@frugalware.org
http://frugalware.org/mailman/listinfo/frugalware-git

Reply via email to