Git-Url: 
http://git.frugalware.org/gitweb/gitweb.cgi?p=multilib.git;a=commitdiff;h=2ce7fa265037e8c5c8ecbd5f84b68bd2adba156e

commit 2ce7fa265037e8c5c8ecbd5f84b68bd2adba156e
Author: crazy <cr...@frugalware.org>
Date:   Mon Feb 12 20:02:58 2018 +0100

evince-3.26.0-3-x86_64

* this one is strange...
* drop nautilus subpackage ( for now ) since is adding weird circualr depends=()
making thinks unbuildable.. While nautilus makedepends=() no-one seems to have
noticed the main package got broken depends=() also. Fixed these ,
however not sure howto solve that nautilus thinggy ..

diff --git a/source/gnome/evince/FrugalBuild b/source/gnome/evince/FrugalBuild
index 3b99d08..dbffb66 100644
--- a/source/gnome/evince/FrugalBuild
+++ b/source/gnome/evince/FrugalBuild
@@ -4,12 +4,12 @@

pkgname=evince
pkgver=3.26.0
-pkgrel=2
+pkgrel=3
pkgdesc="A document viewer for GNOME"
-depends=('gtk+3>=3.22.2A' 'libsecret>=0.18.5-2' 
'gsettings-desktop-schemas>=3.24.1-2' \
+depends=('gtk+3>=3.22.2A' 'libsecret>=0.18.5-2' 'gnome-desktop' 
'gsettings-desktop-schemas>=3.24.1-2' \
'djvulibre>=3.5.27-4' 'libspectre>=0.2.8-2' 'libgxps>=0.2.3.2-3' 
't1lib>=5.1.2-4' \
-       'poppler-glib>=0.60.1-2' 'texlive-kpathsea>=20160523-4')
-makedepends=('itstool>=2.0.2-3' 'intltool>=0.51.0-4' 'nautilus>=3.26.0' 
'gobject-introspection>=1.54.0' 'texlive>=20160523-4')
+       'poppler-glib>=0.60.1-2' 'texlive-kpathsea>=20160523-4' 
'gst1-plugins-base')
+makedepends=('itstool>=2.0.2-3' 'intltool>=0.51.0-4' 
'gobject-introspection>=1.54.0' 'texlive>=20160523-4')
replaces=('gpdf')
groups=('gnome')
archs=("x86_64")
@@ -27,23 +27,23 @@ Fconfopts+=" --disable-static --enable-introspection 
--enable-comics=yes \
--enable-djvu=yes \
--enable-xps=yes \
--enable-pdf=yes \
-        --enable-t1lib=yes"
+        --enable-t1lib=yes --disable-nautilus"

-subpkgs=('evince-nautilus')
-subdescs=('Evince plugin for Nautilus')
-subdepends=("nautilus>=3.26.0")
-subrodepends=("$pkgname=$pkgver")
-subgroups=('gnome')
-subarchs=("x86_64")
-subreplaces=('')
-subprovides=('')
+#subpkgs=('evince-nautilus')
+#subdescs=('Evince plugin for Nautilus')
+#subdepends=("nautilus>=3.26.0")
+#subrodepends=("$pkgname=$pkgver")
+#subgroups=('gnome')
+#subarchs=("x86_64")
+#subreplaces=('')
+#subprovides=('')


build() {
Fbuild

# evince-nautilus package
-        Fsplit evince-nautilus usr/lib/nautilus/
+        #Fsplit evince-nautilus usr/lib/nautilus/

Fbuild_gnome_scriptlet
}
_______________________________________________
Frugalware-git mailing list
Frugalware-git@frugalware.org
http://frugalware.org/mailman/listinfo/frugalware-git

Reply via email to