Git-Url: 
http://git.frugalware.org/gitweb/gitweb.cgi?p=frugalware-current.git;a=commitdiff;h=cbb286c8cf25569cf5cc0114b78d8445b53c4bad

commit cbb286c8cf25569cf5cc0114b78d8445b53c4bad
Author: Miklos Vajna <vmik...@frugalware.org>
Date:   Sat Jun 27 01:02:21 2009 +0200

openoffice.org-3.1.0-2-i686

- update to newer ooo-build snapshot
- rebuild with gcc-4.4, libxaw-1.0.5 and java-gcj-compat-1.0.80-2
- disable kde4 support for now

diff --git a/source/xapps/openoffice.org/FrugalBuild 
b/source/xapps/openoffice.org/FrugalBuild
index 83b5dca..12d024d 100644
--- a/source/xapps/openoffice.org/FrugalBuild
+++ b/source/xapps/openoffice.org/FrugalBuild
@@ -11,8 +11,8 @@ if ! Fuse $USE_DEVEL; then
dir=`echo $tree|tr [a-z] [A-Z]`
milestone=11
pkgver=$upstream
-       pkgrel=1
-       snapshot=bb48d86
+       pkgrel=2
+       snapshot=1850412
else
upstream=3.1.0
branch=-3-1
@@ -28,16 +28,16 @@ url="http://www.openoffice.org/";
_F_gnome_desktop="y"
Finclude gnome-scriptlet mono java
install=openoffice.org.install
-depends=('libxml2' 'libart_lgpl' 'libsndfile' 'libgcj-awt>=4.1.1-6' 'nas' 
'fontconfig' 'libpng' 'imagemagick' \
+depends=('libxml2' 'libart_lgpl' 'libsndfile' 'libgcj-awt>=4.4.0-2' 'nas' 
'fontconfig' 'libpng' 'imagemagick' \
'flex' 'neon>=0.26.1' 'bison' 'zip' 'unzip' 'expat' 'cups' 'desktop-file-utils' 
'perl-archive-zip' \
-        'unixodbc' 'libxaw' 'libxslt' 'startup-notification' 'libwpd>=0.8.13' 
'poppler')
+        'unixodbc' 'libxaw>=1.0.5' 'libxslt' 'startup-notification>=0.9-3' 
'libwpd>=0.8.13' 'poppler')
# this is here as gstreamer is only a makedepend
rodepends=('flac' 'dejavu-ttf')
-makedepends=(${makedepen...@]} 'curl' 'intltool' 'tcsh' 'pam-headers' 
'apache-ant' 'kdelibs>=3.5.5' \
+makedepends=(${makedepen...@]} 'curl' 'intltool' 'tcsh' 'pam-headers' 
'apache-ant' 'kdelibs>=3.5.10-3' \
'evolution-data-server-ldap' 'boost' 'icu' 'hunspell' 'imake' 'gccmakedep' 
'xalan-j' \
'patch>=2.5.9' 'openclipart' 'xorg-server' 'gstreamer' 'gst-plugins-base' 
'gnome-vfs' \
'libbonobo' 'procps' 'openldap' 'mono' 'gperf' 'xulrunner' \
-            'java-gcj-compat>=1.0.72-7' 'ecj')
+            'java-gcj-compat>=1.0.80-2' 'ecj')
groups=('xapps')
archs=('i686' 'x86_64')
if ! Fuse $USE_DEVEL; then
@@ -184,7 +184,8 @@ build()
--with-binsuffix=no \
--disable-dependency-tracking \
--with-installed-ooo-dirname=openoffice.org\
-               --disable-odk"
+               --disable-odk \
+               --disable-kde4"

# Set our version.
Fsed "AC_PACKAGE_VERSION" "$pkgver-$pkgrel" configure.in
_______________________________________________
Frugalware-git mailing list
Frugalware-git@frugalware.org
http://frugalware.org/mailman/listinfo/frugalware-git

Reply via email to