Git-Url: 
http://git.frugalware.org/gitweb/gitweb.cgi?p=nvidia.git;a=commitdiff;h=ac34da5e34f117188bb7f6e018b25bc9ecd2d503

commit ac34da5e34f117188bb7f6e018b25bc9ecd2d503
Author: András Vöröskői <voros...@frugalware.org>
Date:   Wed Jul 1 18:38:22 2009 +0200

net6-1.3.9-2-i686

rebuilt with gnutls>=2.8
add net6.git-1a1216523ef29c9f7168f0d2e1917edd4463a142.patch

diff --git a/source/lib-extra/net6/FrugalBuild 
b/source/lib-extra/net6/FrugalBuild
index a19d50f..b8d0601 100644
--- a/source/lib-extra/net6/FrugalBuild
+++ b/source/lib-extra/net6/FrugalBuild
@@ -4,14 +4,26 @@

pkgname=net6
pkgver=1.3.9
-pkgrel=1
+pkgrel=2
pkgdesc="net6 is a library which eases the development of network-based 
applications"
url="http://releases.0x539.de/net6/";
-depends=('libsigc++2' 'gnutls>=2.6')
+# Fautoreconf needs it
+makedepends=('cvs')
+depends=('libsigc++2' 'gnutls>=2.8')
groups=('lib-extra')
archs=('i686' 'x86_64')
up2date="lynx -dump $url | sed '/latest/d' | sed '/stable/d' | Flasttar"
-source=($url/$pkgname-$pkgver.tar.gz)
-sha1sums=('86c15f3b3bcd89bfa8da9cef68518b32349ba36f')
+source=($url/$pkgname-$pkgver.tar.gz \
+       net6.git-1a1216523ef29c9f7168f0d2e1917edd4463a142.patch)
+sha1sums=('86c15f3b3bcd89bfa8da9cef68518b32349ba36f' \
+          '3e2c320b2bf7c46b002b553af1d6962d29943c60')
+
+build() {
+       Fcd
+       Fpatchall
+       Fautoreconf
+       Fmake
+       Fmakeinstall
+}

# optimization OK
diff --git 
a/source/lib-extra/net6/net6.git-1a1216523ef29c9f7168f0d2e1917edd4463a142.patch 
b/source/lib-extra/net6/net6.git-1a1216523ef29c9f7168f0d2e1917edd4463a142.patch
new file mode 100644
index 0000000..b2a53aa
--- /dev/null
+++ 
b/source/lib-extra/net6/net6.git-1a1216523ef29c9f7168f0d2e1917edd4463a142.patch
@@ -0,0 +1,50 @@
+From: Armin Burgmeier <ar...@arbur.net>
+Date: Fri, 22 May 2009 18:25:55 +0000 (+0200)
+Subject: Locate gnutls via pkg-config, not libgnutls-config
+X-Git-Url: 
http://git.0x539.de/?p=net6.git;a=commitdiff_plain;h=1a1216523ef29c9f7168f0d2e1917edd4463a142
+
+Locate gnutls via pkg-config, not libgnutls-config
+
+2009-05-22  Armin Burgmeier  <ar...@0x539.de>
+
+       * configure.ac: Locate gnutls via pkg-config, not libgnutls-config
+       which newer versions no longer have.
+---
+
+diff --git a/ChangeLog b/ChangeLog
+index 76875c1..a2cfd00 100644
+--- a/ChangeLog
++++ b/ChangeLog
+@@ -1,3 +1,8 @@
++2009-05-22  Armin Burgmeier  <ar...@0x539.de>
++
++      * configure.ac: Locate gnutls via pkg-config, not libgnutls-config
++      which newer versions no longer have.
++
+ 2009-01-03  Philipp Kern  <p...@0x539.de>
+
+       * configure.ac:
+diff --git a/configure.ac b/configure.ac
+index b246cc5..401083c 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -72,18 +72,7 @@ AC_SUBST(addlibs)
+ AM_CONDITIONAL(WIN32, test x$win32 = xtrue)
+
+ # Checks for libraries.
+-PKG_CHECK_MODULES([libnet6], [sigc++-2.0])
+-
+-AM_PATH_LIBGNUTLS( 1.0.0,, AC_MSG_ERROR([[
+-***
+-*** libgnutls was not found. You may want to get it by using the
+-*** package manager of your distribution or by compiling the source
+-*** from ftp://ftp.gnutls.org/pub/gnutls/. This dependency is
+-*** now mandatory.
+-]]))
+-addlibs="$addlibs $LIBGNUTLS_LIBS"
+-addcflags="$LIBGNUTLS_CFLAGS"
+-AC_SUBST(addcflags)
++PKG_CHECK_MODULES([libnet6], [sigc++-2.0, gnutls])
+
+ # gettext / i18n
+ AM_GNU_GETTEXT([external])
_______________________________________________
Frugalware-git mailing list
Frugalware-git@frugalware.org
http://frugalware.org/mailman/listinfo/frugalware-git

Reply via email to