Git-Url: 
http://git.frugalware.org/gitweb/gitweb.cgi?p=kdenext.git;a=commitdiff;h=925eb6fb1debbdc50668720a8d437fc3f50b6c92

commit 925eb6fb1debbdc50668720a8d437fc3f50b6c92
Author: crazy <cr...@frugalware.org>
Date:   Thu Aug 12 17:20:00 2010 +0200

kdebase-workspace-4.5.0-1-x86_64
* Version bump
* (a lot stuff need fixing here .. )

diff --git a/source/kde/kdebase-workspace/FrugalBuild 
b/source/kde/kdebase-workspace/FrugalBuild
index 1a87b49..88df7ff 100644
--- a/source/kde/kdebase-workspace/FrugalBuild
+++ b/source/kde/kdebase-workspace/FrugalBuild
@@ -12,7 +12,7 @@ rodepends=("${rodepen...@]}" 'xorg-server>=1.6.1' 
'kde-frugalware>=4.3' \
'xsetroot' 'xmessage' 'xrandr' 'xset' 'xprop' 'xrdb' 'dbus-x11' 
'consolekit-x11')
depends=()
makedepends=("${makedepen...@]}" "ksgmltools2>=$_F_kde_ver"
-       'python' 'boost' 'bluez-libs' "libkdewidgets>=$_F_kde_ver" 
"libqtdesigner>=$_F_kde_qtver" "networkmanager>=0.8") ## SURE! libkdewidgets is 
a DEVEL only thing I see :P
+       'python' 'boost' 'bluez-libs' "libkdewidgets>=$_F_kde_ver" 
"libqtdesigner>=$_F_kde_qtver" "networkmanager>=0.8" "libkdewebkit") ## SURE! 
libkdewidgets is a DEVEL only thing I see :P
##FIXME and send upstream! ksysgurds lib want libqtdesigner but no check for it 
so compile error same libkdewidgets
## xrdb needed by font part .. from code in fonts.cpp ->:
## " proc << "xrdb" << "-quiet" << "-remove" << "-nocpp"; "
@@ -20,8 +20,8 @@ source=("${sour...@]}" \
kde.desktop \
kde.pamd \
kde-np.pamd \
-        04-systemsettings-root.patch \
-        05-Suse-kdm-make_it_cool.diff \
+        #04-systemsettings-root.patch \
+        #05-Suse-kdm-make_it_cool.diff \
07-kspalsh-fix.patch \
10-kxftconfig-defaults.patch \
12-cursors-location.patch \
@@ -31,18 +31,17 @@ source=("${sour...@]}" \
#replaces=('ksensors' 'katapult' 'tastymenu' 'kbfx' 'kdesktop-menu' \
#       'kicker-compiz' 'taskbar-compiz' 'mtaskbar' 'ksmoothdock' \
#       'kompose' 'dbus-qt3')
-sha1sums=('d0defe431a760503f8fbb9ee2413b666b3c84cd7' \
+sha1sums=('86648def4f6c1791ed385b649b867d9a38db6e1c' \
'e1f706c984fc81633663c662e674b6f2c64d2f83' \
'9ff7d6cf01f42d513cf16a0d2c302cadde38f857' \
'4632f6e2a199f91f8aa068e0335dbae43813aaed' \
-          'cb5353c2238cc8c38f4dda8eb51373fe7ea17428' \
-          '5b16b82ff8f0084d15db9adf98c423906ff816e9' \
'be19f30fcffd85e899d7557c4b483d5c16f15b7e' \
'ff0ffac7528cf3a0c51f1f31933ac0ea059396b3' \
'454f18f51d225d8e9c05985ea42a0a713727f964' \
'45d16ed762567bd48ef216a11804bb9f5c61bfce' \
'2d98bfd2e01c13a15568afb83049f5acb64cd842')

+#FIXME add all new subpkgs
Qt4="${_F_kde_qtver}"
Kde4="$_F_kde_ver"

@@ -80,6 +79,15 @@ subgroups=("${subgrou...@]}" 'kde kde-core')
subreplaces=("${subreplac...@]}" '')
subarchs=("${subarc...@]}" 'i686 x86_64 ppc')

+subpkgs=("${subpk...@]}" "kinfocenter")
+subdescs=("${subdes...@]}" "The KDE Info Center.")
+subdepends=("${subdepen...@]}" "libkhtml>=$Kde4 libkutils>=$Kde4 
libqtnetwork>=$Qt4 libqtxml>=$Qt4 libxtst libice libxfixes libxrender xz libxau
+               libxdmcp strigi>=0.7.2-2 xfsprogs-acl libuuid libglu 
libkde3support>=$Kde4 libqtsql>=$Qt4 libraw1394 pciutils")
+subrodepends=("${subrodepen...@]}" '')
+subgroups=("${subgrou...@]}" 'kde kde-core')
+subreplaces=("${subreplac...@]}" '')
+subarchs=("${subarc...@]}" 'i686 x86_64 ppc')
+
subpkgs=("${subpk...@]}" "systemsettings")
subdescs=("${subdes...@]}" "Central configuration center for KDE.")
subdepends=("${subdepen...@]}" "libkutils>=$Kde4 libqtnetwork>=$Qt4 xz 
polkit-qt-1 libxtst libqtsvg>=$Qt4 libice libqtxml>=$Qt4 libxcursor libgcc
@@ -191,6 +199,15 @@ subgroups=("${subgrou...@]}" 'kde kde-core')
subreplaces=("${subreplac...@]}" '')
subarchs=("${subarc...@]}" 'i686 x86_64 ppc')

+subpkgs=("${subpk...@]}" "kstyles")
+subdescs=("${subdes...@]}" "Runtime Files for Kstyles.")
+subdepends=("${subdepen...@]}" "libkdecore>=$Kde4 libqtgui>=$Qt4 
libqtdbus>=$Qt4 bzip2 libxext polkit-qt-1 gamin xfsprogs-attr")
+subrodepends=("${subrodepen...@]}" "")
+subgroups=("${subgrou...@]}" "kde kde-core")
+subreplaces=("${subreplac...@]}" "kdebase-runtime-kstyles")
+subarchs=("${subarc...@]}" "i686 x86_64 ppc")
+
+
## libs/<..> - auto-split

subpkgs=("${subpk...@]}" "libkephal")
_______________________________________________
Frugalware-git mailing list
Frugalware-git@frugalware.org
http://frugalware.org/mailman/listinfo/frugalware-git

Reply via email to