Git-Url: 
http://git.frugalware.org/gitweb/gitweb.cgi?p=kdetesting2.git;a=commitdiff;h=8d35ee7dc9eee85cbf6c15d03682bc7ebba121f3

commit 8d35ee7dc9eee85cbf6c15d03682bc7ebba121f3
Author: Miklos Vajna <vmik...@frugalware.org>
Date:   Sat Jan 1 13:47:26 2011 +0100

apache-ant-1.8.2-1-i686

- version bump
- enable doc, now that we build using openjdk

diff --git a/source/devel-extra/apache-ant/FrugalBuild 
b/source/devel-extra/apache-ant/FrugalBuild
index 1f5be41..f308cb9 100644
--- a/source/devel-extra/apache-ant/FrugalBuild
+++ b/source/devel-extra/apache-ant/FrugalBuild
@@ -2,7 +2,7 @@
# Maintainer: Miklos Vajna <vmik...@frugalware.org>

pkgname=apache-ant
-pkgver=1.8.1
+pkgver=1.8.2
pkgrel=1
pkgdesc="Ant is a Java-based build tool."
url="http://ant.apache.org";
@@ -11,9 +11,10 @@ archs=('i686' 'x86_64' 'ppc')
up2date="lynx -dump $url/srcdownload.cgi|grep bz2$|sed 's/.*-\(.*\)-.*/\1/'"
source=(http://www.apache.org/dist/ant/source/apache-ant-$pkgver-src.tar.bz2)
signatures=($source.asc)
+_F_java_no_gcj=1
Finclude java
-depends=('java-gcj-compat>=1.0.68')
-makedepends=('ecj' 'gcc-gcj')
+depends=('openjre')
+makedepends=('openjdk')

build()
{
@@ -26,9 +27,6 @@ build()

# disable junit as it depends on stuff that requires ant
Fsed "depends=\"jars,test-jar\"" "depends=\"jars\"" build.xml
-       # disable javadoc, gjdoc is known to be broken, but openjdk
-       # already requires ant
-       Fsed "depends=\"dist-lite,dist_javadocs\"" "depends=\"dist-lite\"" 
build.xml
./build.sh -Ddist.dir=dist/ dist || return 1

Fmkdir /usr/bin /usr/share/doc/$pkgname-$pkgver
_______________________________________________
Frugalware-git mailing list
Frugalware-git@frugalware.org
http://frugalware.org/mailman/listinfo/frugalware-git

Reply via email to