Git-Url: 
http://git.frugalware.org/gitweb/gitweb.cgi?p=gnometesting.git;a=commitdiff;h=9530ad086c56d3c83ffe36c20af15f6aa438cbc0

commit 9530ad086c56d3c83ffe36c20af15f6aa438cbc0
Author: bouleetbil <bouleet...@frogdev.info>
Date:   Wed Feb 2 21:45:17 2011 +0100

avahi-0.6.28-1-x86_64
*version bump
*added gtk3 support

diff --git a/source/network/avahi/FrugalBuild b/source/network/avahi/FrugalBuild
index b960e1e..5fa3802 100644
--- a/source/network/avahi/FrugalBuild
+++ b/source/network/avahi/FrugalBuild
@@ -3,8 +3,8 @@
# Contributor: AlexExtreme <a...@alex-smith.me.uk>

pkgname=avahi
-pkgver=0.6.25
-pkgrel=6
+pkgver=0.6.28
+pkgrel=1
pkgdesc="A multicast/unicast DNS-SD framework"
archs=('i686' 'x86_64' 'ppc')
url="http://www.avahi.org";
@@ -21,27 +21,28 @@ source=(http://avahi.org/download/$pkgname-$pkgver.tar.gz \
rc.avahi-daemon{,-hu.po} rc.avahi-dnsconfd{,-hu.po} \
README.Frugalware)
Finclude mono
-sha1sums=('7ce8ed5a494d72401dd81f64594fda59d2ec91fd' \
+sha1sums=('5da3f7da2cff8ddf74f8746e4dcb2524e5047f67' \
'926faad00a60b3208e4036c73e71f78dbc6dace9' \
'5f6b99e4917458b24736519bdd1e510763310589' \
'723e2e691d35063bd8aefeaf1063fdba812a9249' \
'b31a9b9bf972739d2976ef510690968851e8b588' \
'3cb0c4904bc323cba78234e4c5430478636fbf44')

-subpkgs=('avahi-glib' 'avahi-sharp' 'avahi-qt3' 'avahi-python' 'avahi-compat' 
'avahi-gtk2' 'avahi-qt4' 'avahi-dnsconfd' 'libavahi-ui' 'libavahi-ui-sharp')
+subpkgs=('avahi-glib' 'avahi-sharp' 'avahi-qt3' 'avahi-python' 'avahi-compat' 
'avahi-gtk2' 'avahi-qt4' 'avahi-dnsconfd' 'libavahi-ui' 'libavahi-ui-sharp' 
'avahi-gtk3')
subdescs=('Glib bindings for Avahi' 'Mono C# bindings for Avahi' 'QT3 bindings 
for Avahi' \
'Python bindings for Avahi' 'mDNSresponder and Howl compatibility 
libraries/headers for Avahi' \
'GUI GTK based tools for Avahi' 'QT4 bindings for Avahi' 'Discovers DNS servers 
broadcast with Avahi on a local network' \
-         'User interface library for Avahi' 'Mono bindings for Avahi-UI')
+         'User interface library for Avahi' 'Mono bindings for Avahi-UI' \
+       'GUI GTK3 based tools for Avahi')
subdepends=("glib2" "mono>=2.8" "qt" "python>=2.7" "" \
"libglade pygtk" "libqtcore" "" \
-           "gtk+2" "gtk2-sharp>=2.12.6")
+           "gtk+2" "gtk2-sharp>=2.12.6" "gtk+3")
subrodepends=("$pkgname=$pkgver" "$pkgname=$pkgver" "$pkgname=$pkgver" " 
$pkgname=$pkgver" \
"$pkgname=$pkgver" "avahi-python=$pkgver libavahi-ui=$pkgver 
avahi-glib=$pkgver" "$pkgname=$pkgver" "$pkgname=$pkgver" \
-       "$pkgname=$pkgver" "libavahi-ui=$pkgver")
-subgroups=('network' 'apps-extra' 'xlib' 'network-extra' 'network' 
'gnome-extra' 'lib-extra' 'network-extra' 'gnome' 'gnome-extra')
+       "$pkgname=$pkgver" "libavahi-ui=$pkgver" "$pkgname=$pkgver")
+subgroups=('network' 'apps-extra' 'xlib' 'network-extra' 'network' 
'gnome-extra' 'lib-extra' 'network-extra' 'gnome' 'gnome-extra' 'gnome')
subarchs=('i686 x86_64 ppc' 'i686 x86_64 ppc' 'i686 x86_64 ppc' 'i686 x86_64 
ppc' 'i686 x86_64 ppc' 'i686 x86_64 ppc' 'i686 x86_64 ppc' \
-         'i686 x86_64 ppc' 'i686 x86_64 ppc' 'i686 x86_64 ppc')
+         'i686 x86_64 ppc' 'i686 x86_64 ppc' 'i686 x86_64 ppc' 'i686 x86_64 
ppc')

unset MAKEFLAGS

@@ -120,6 +121,10 @@ build() {
Fsplit avahi-gtk2 usr/bin/bssh
Fsplit avahi-gtk2 usr/bin/bvnc

+       Fsplit avahi-gtk3 usr/lib/libavahi-ui-gtk3.so.*
+       Fsplit avahi-gtk3 usr/lib/libavahi-ui.so
+       Fsplit avahi-gtk3 usr/lib/pkgconfig/avahi-ui-gtk3.pc
+
# libavahi-ui
Fsplit libavahi-ui usr/include/avahi-ui
Fsplit libavahi-ui usr/lib/libavahi-ui*
_______________________________________________
Frugalware-git mailing list
Frugalware-git@frugalware.org
http://frugalware.org/mailman/listinfo/frugalware-git

Reply via email to