Git-Url: 
http://git.frugalware.org/gitweb/gitweb.cgi?p=gnometesting.git;a=commitdiff;h=6eec881b0630641e1bf2f366a5c47468ada97a7d

commit 6eec881b0630641e1bf2f366a5c47468ada97a7d
Author: Devil505 <devil505li...@gmail.com>
Date:   Thu Feb 24 08:27:45 2011 +0100

libindicate-0.4.93-2-i686
* version bump
* pkgrel++

diff --git a/source/xlib-extra/libindicate/FrugalBuild 
b/source/xlib-extra/libindicate/FrugalBuild
index 73134b7..fd6cb30 100644
--- a/source/xlib-extra/libindicate/FrugalBuild
+++ b/source/xlib-extra/libindicate/FrugalBuild
@@ -2,23 +2,23 @@
# Maintainer: Devil505 <devil505li...@gmail.com>

pkgname=libindicate
-pkgver=0.4.4
-pkgrel=5
+pkgver=0.4.93
+pkgrel=2
pkgdesc="A small library for applications to raise 'flags' on DBus for other 
components of the desktop to pick up and visualize."
url="https://launchpad.net/libindicate";
-depends=('libdbusmenu>=0.3.90')
+depends=('libdbusmenu>=0.3.98-3')
makedepends=('gnome-doc-utils' 'vala')
_F_mono_aot=0
Finclude mono python
groups=('xlib-extra')
archs=('i686' 'x86_64' 'ppc')
up2date="Flasttar $url"
-source=($url/0.4/${pkgver}/+download/${pkgname}-${pkgver}.tar.gz)
-sha1sums=('0dc3ad4c35581adea9d9ae89daacf820c764f24a')
+source=($url/0.5/${pkgver}/+download/${pkgname}-${pkgver}.tar.gz)
+sha1sums=('642aa0ebdeab085c22293cd9d59eec30b7218f19')

subpkgs=("${subpkgs[@]}" "$pkgname-gtk")
subdescs=("${subdescs[@]}" "GTK bindings for libindicate")
-subdepends=("${subdepends[@]}" "")
+subdepends=("${subdepends[@]}" "gtk+2")
subrodepends=("${subrodepends[@]}" "$pkgname")
subgroups=("${subgroups[@]}" 'xlib-extra')
subarchs=("${subarchs[@]}" 'i686 x86_64 ppc')
@@ -39,17 +39,13 @@ subarchs=("${subarchs[@]}" 'i686 x86_64 ppc')

build() {
Fcd
-       #Python fix
-       Fsed "-lpyglib-2.0-python2.6" "-lpyglib-2.0-python" 
bindings/python/Makefile.am
-       Fsed "-lpyglib-2.0-python2.6" "-lpyglib-2.0-python" 
bindings/python/Makefile.in
-       Fsed "-lpython2.6" "-lpython2.7" bindings/python/Makefile.am
-       Fsed "-lpython2.6" "-lpython2.7" bindings/python/Makefile.in
+       sed -i 's/-lpyglib-2\.0-python$PYTHON_VERSION/-lpyglib-2\.0-python/' 
configure{,.ac} || Fdie

Fbuild_mono
Fsplit $pkgname-gtk usr/lib/libindicate-gtk.*
-       Fsplit $pkgname-gtk usr/include/libindicate-0.2/libindicate-gtk
+       Fsplit $pkgname-gtk usr/include/libindicate-0.5/libindicate-gtk
Fsplit $pkgname-gtk usr/share/gtk-doc/
-       Fsplit $pkgname-gtk usr/lib/pkgconfig/indicate-gtk.pc
+       Fsplit $pkgname-gtk usr/lib/pkgconfig/indicate-gtk-0.5.pc
Fsplit $pkgname-python $_F_python_libdir
Fsplit $pkgname-python usr/share/pygtk/
Fsplit $pkgname-mono usr/lib/mono/
_______________________________________________
Frugalware-git mailing list
Frugalware-git@frugalware.org
http://frugalware.org/mailman/listinfo/frugalware-git

Reply via email to