Git-Url: 
http://git.frugalware.org/gitweb/gitweb.cgi?p=frugalware-current.git;a=commitdiff;h=49e093f1143c82bd94828660a7c7dec545b6f979

commit 49e093f1143c82bd94828660a7c7dec545b6f979
Author: Miklos Vajna <vmik...@frugalware.org>
Date:   Fri Mar 4 13:22:16 2011 +0100

frugalwareutils-0.9.3-6-i686

- depend on systemd for service file handling in install scriptlet

diff --git a/source/base/frugalwareutils/FrugalBuild 
b/source/base/frugalwareutils/FrugalBuild
index 2a8a8b8..e4f7508 100644
--- a/source/base/frugalwareutils/FrugalBuild
+++ b/source/base/frugalwareutils/FrugalBuild
@@ -7,11 +7,12 @@ USE_APIDOCS=${USE_APIDOCS:-"y"}
pkgname=frugalwareutils
pkgver=0.9.3
Fuse $USE_DEVEL && pkgver=0.8.7.6.g3d85830
-pkgrel=5
+pkgrel=6
pkgdesc="Frugalware configuration utilities."
url="http://ftp.frugalware.org/pub/other/frugalwareutils";
depends=('glib2>=2.16.4-2' 'ncurses>=5.6-4' 'parted>=2.3' \
'pacman-g2>=3.7.0-4' 'pciutils')
+rodepends=('systemd')
makedepends=('dialog>=1.1_20080316-2' 'asciidoc' 'docbook-xsl' \
'docbook-xml' 'sgml-common' 'po4a')
Fuse $USE_APIDOCS && makedepends=("${makedepends[@]}" 'doxygen')
diff --git a/source/base/frugalwareutils/frugalwareutils.install 
b/source/base/frugalwareutils/frugalwareutils.install
index 4b06c48..e4332e6 100644
--- a/source/base/frugalwareutils/frugalwareutils.install
+++ b/source/base/frugalwareutils/frugalwareutils.install
@@ -1,20 +1,11 @@
post_install()
{
-       # don't use systemctl enable yet, it may not be available
-       mkdir -p /etc/systemd/system/{network,multi-user}.target.wants
-       ln -s '/lib/systemd/system/netconfig.service' 
'/etc/systemd/system/network.target.wants/netconfig.service'
-       ln -s '/lib/systemd/system/netconfig.service' 
'/etc/systemd/system/multi-user.target.wants/netconfig.service'
-       systemctl daemon-reload >/dev/null 2>&1
+       systemctl enable netconfig.service >/dev/null 2>&1
}

post_upgrade()
{
systemctl daemon-reload >/dev/null 2>&1
-       systemctl try-restart netconfig.service >/dev/null 2>&1
-       # for systemd, can be removed after Frugalware-1.4 is out
-       if [ -f /etc/HOSTNAME -a ! -f /etc/hostname ]; then
-               cat /etc/HOSTNAME | cut -f1 -d . > /etc/hostname
-       fi
if [ `vercmp $2 0.9.3-3` -lt 0 ] ; then
post_install
fi
@@ -23,9 +14,7 @@ post_upgrade()
pre_remove()
{
systemctl stop netconfig.service >/dev/null 2>&1
-       # don't use systemctl disable yet, either
-       rm -f /etc/systemd/system/network.target.wants/netconfig.service
-       rm -f /etc/systemd/system/multi-user.target.wants/netconfig.service
+       systemctl --no-reload disable netconfig.service >/dev/null 2>&1
}

post_remove()
_______________________________________________
Frugalware-git mailing list
Frugalware-git@frugalware.org
http://frugalware.org/mailman/listinfo/frugalware-git

Reply via email to