Git-Url: 
http://git.frugalware.org/gitweb/gitweb.cgi?p=kdetesting2.git;a=commitdiff;h=39f44b6003f95c2fe9a4dd1970e613c2d2c25168

commit 39f44b6003f95c2fe9a4dd1970e613c2d2c25168
Author: Michel Hermier <herm...@frugalware.org>
Date:   Sat Aug 6 14:57:09 2011 +0200

kdelibs-4.7.0-4-i686

* Rename libkdecore to kdelibs-core. It will be a meta package soon and
I will need the libkdecore package name.

diff --git a/source/kde/kdelibs/FrugalBuild b/source/kde/kdelibs/FrugalBuild
index 1d5f17d..6b76582 100644
--- a/source/kde/kdelibs/FrugalBuild
+++ b/source/kde/kdelibs/FrugalBuild
@@ -2,12 +2,11 @@
# Maintainer: centuri0 <achevaux at gmail dot com>

pkgname=kdelibs
-pkgrel=3
+pkgrel=4
pkgdesc="KDE4 Core Libraries."
groups=('kde')
replaces=('kat')
archs=('i686' 'x86_64' 'ppc')
-_F_kde_subpkgs_custom_path=1
Finclude kde
depends=()
## for now
@@ -22,7 +21,6 @@ sha1sums=("${sha1sums[@]}" \

DNSSDDEP="libdnssd>=$_F_kde_ver"
KDE3SUPPORTDEP="libkde3support>=$_F_kde_ver"
-KDECOREDEP="libkdecore>=$_F_kde_ver"
KDESUDEP="libkdesu>=$_F_kde_ver"
WEBKITDEP="libkdewebkit>=$_F_kde_ver"
KFILEDEP="libkfile>=$_F_kde_ver"
@@ -35,6 +33,8 @@ NEPOMUKDEP="libnepomuk>=$_F_kde_ver"
PLASMADEP="libplasma>=$_F_kde_ver"
THREADWDEP="libthreadweaver>=$_F_kde_ver"

+KDELIBS_COREDEP="kdelibs-core>=$_F_kde_ver"
+
PHONONDEP="phonon>=4.4.0-2"
POLKIT_QT_1DEP="polkit-qt-1>=0.99.0"

@@ -66,7 +66,7 @@ subpkgs=("${subpkgs[@]}" "libkde3support")
subdescs=("${subdescs[@]}" "Libraries to support KDE3 code.")
subdepends=("${subdepends[@]}" "$LIBQTDBUSDEP $LIBQT3SUPPORTDEP $LIBQTSVGDEP
$POLKIT_QT_1DEP gamin xfsprogs-attr libsm libxcursor libpng fontconfig libxi")
-subrodepends=("${subrodepends[@]}" "$KDECOREDEP $KDESUDEP")
+subrodepends=("${subrodepends[@]}" "$KDELIBS_COREDEP $KDESUDEP")
subgroups=("${subgroups[@]}" 'kde kde-core')
subarchs=("${subarchs[@]}" 'i686 x86_64 ppc')

@@ -74,21 +74,21 @@ subpkgs=("${subpkgs[@]}" "libplasma")
subdescs=("${subdescs[@]}" "Framework for the KDE desktop shell and its 
widgets.")
subdepends=("${subdepends[@]}" "$LIBQTUITOOLSDEP $LIBQTWEBKITDEP $LIBQTOPENGLDEP
qca gamin xfsprogs-attr libqtdbus libxcb libxdamage $POLKIT_QT_1DEP")
-subrodepends=("${subrodepends[@]}" "$KDECOREDEP $KNEWDEP $THREADWDEP 
$DNSSDDEP")
+subrodepends=("${subrodepends[@]}" "$KDELIBS_COREDEP $KNEWDEP $THREADWDEP 
$DNSSDDEP")
subgroups=("${subgroups[@]}" 'kde kde-core')
subarchs=("${subarchs[@]}" 'i686 x86_64 ppc')

subpkgs=("${subpkgs[@]}" "libdnssd")
subdescs=("${subdescs[@]}" "Interface to support the DNS-SD (Zeroconf) 
protocol.")
subdepends=("${subdepends[@]}" "$LIBQTDBUSDEP $LIBQTGUIDEP bzip2 libxext 
$POLKIT_QT_1DEP avahi")
-subrodepends=("${subrodepends[@]}" "$KDECOREDEP")
+subrodepends=("${subrodepends[@]}" "$KDELIBS_COREDEP")
subgroups=("${subgroups[@]}" 'kde kde-core')
subarchs=("${subarchs[@]}" 'i686 x86_64 ppc')

subpkgs=("${subpkgs[@]}" "libknotify")
subdescs=("${subdescs[@]}" "User Notification Libraries.")
subdepends=("${subdepends[@]}" "$PHONONDEP gamin xfsprogs-attr bzip2 libxext 
$POLKIT_QT_1DEP")
-subrodepends=("${subrodepends[@]}" "$KDECOREDEP phonon-backend-vlc")
+subrodepends=("${subrodepends[@]}" "$KDELIBS_COREDEP phonon-backend-vlc")
subgroups=("${subgroups[@]}" 'kde kde-core')
subarchs=("${subarchs[@]}" 'i686 x86_64 ppc')

@@ -96,35 +96,35 @@ subpkgs=("${subpkgs[@]}" "libkross")
subdescs=("${subdescs[@]}" "Scripting Libraries.")
subdepends=("${subdepends[@]}" "$LIBQTSVGDEP $LIBQTDBUSDEP $LIBQTDESIGNERDEP
gamin xfsprogs-attr libpng fontconfig libxi $POLKIT_QT_1DEP libsm libxcursor")
-subrodepends=("${subrodepends[@]}" "$KDECOREDEP $KFILEDEP 
libkjsembed>=$_F_kde_ver")
+subrodepends=("${subrodepends[@]}" "$KDELIBS_COREDEP $KFILEDEP 
libkjsembed>=$_F_kde_ver")
subgroups=("${subgroups[@]}" 'kde kde-core')
subarchs=("${subarchs[@]}" 'i686 x86_64 ppc')

subpkgs=("${subpkgs[@]}" "libkdewebkit")
subdescs=("${subdescs[@]}" "KDE WebKit Library")
subdepends=("${subdepends[@]}" "$LIBQTWEBKITDEP $LIBQTGUIDEP $LIBQTDBUSDEP 
gamin xfsprogs-attr bzip2 libxext libxcb $POLKIT_QT_1DEP")
-subrodepends=("${subrodepends[@]}" "$KDECOREDEP")
+subrodepends=("${subrodepends[@]}" "$KDELIBS_COREDEP")
subgroups=("${subgroups[@]}" 'kde kde-core')
subarchs=("${subarchs[@]}" 'i686 x86_64 ppc')

subpkgs=("${subpkgs[@]}" "libkhtml")
subdescs=("${subdescs[@]}" "HTML rendering widget designed for Konqueror.")
subdepends=("${subdepends[@]}" "$LIBQTGUIDEP $LIBQTDBUSDEP libjpeg>=8a libgif 
pcre libxcb gamin xfsprogs-attr libxext bzip2 $POLKIT_QT_1DEP")
-subrodepends=("${subrodepends[@]}" "$KDECOREDEP 
kdelibs-interfaces>=$_F_kde_ver")
+subrodepends=("${subrodepends[@]}" "$KDELIBS_COREDEP 
kdelibs-interfaces>=$_F_kde_ver")
subgroups=("${subgroups[@]}" 'kde kde-core')
subarchs=("${subarchs[@]}" 'i686 x86_64 ppc')

subpkgs=("${subpkgs[@]}" "libkfile")
subdescs=("${subdescs[@]}" "File management widgets and dialogs libraries.")
subdepends=("${subdepends[@]}" "$LIBQTGUIDEP $LIBQTDBUSDEP gamin xfsprogs-attr 
bzip2 libxext $POLKIT_QT_1DEP")
-subrodepends=("${subrodepends[@]}" "$KDECOREDEP")
+subrodepends=("${subrodepends[@]}" "$KDELIBS_COREDEP")
subgroups=("${subgroups[@]}" 'kde kde-core')
subarchs=("${subarchs[@]}" 'i686 x86_64 ppc')

subpkgs=("${subpkgs[@]}" "libknewstuff")
subdescs=("${subdescs[@]}" "Allows applications to easily download data from 
the Internet.")
-subdepends=("${subdepends[@]}" "$LIBQTGUIDEP $LIBQTDBUSDEP gamin xfsprogs-attr 
bzip2 libxext $POLKIT_QT_1DEP attica>=0.1.2")
-subrodepends=("${subrodepends[@]}" "$KDECOREDEP")
+subdepends=("${subdepends[@]}" "$LIBQTGUIDEP $LIBQTDBUSDEP gamin xfsprogs-attr 
bzip2 libxext $POLKIT_QT_1DEP")
+subrodepends=("${subrodepends[@]}" "$KDELIBS_COREDEP")
subgroups=("${subgroups[@]}" 'kde kde-core')
subarchs=("${subarchs[@]}" 'i686 x86_64 ppc')

@@ -132,21 +132,21 @@ subpkgs=("${subpkgs[@]}" "libkdewidgets")
subdescs=("${subdescs[@]}" "KDE custom widgets for Qt Designer.")
subdepends=("${subdepends[@]}" "$LIBQTGUIDEP $LIBQTNETWORKDEP $LIBQTDBUSDEP 
$LIBQTSQLDEP
libstdc++ zlib strigi>=0.7.2 xfsprogs-acl libxrender libice libxext 
$POLKIT_QT_1DEP")
-subrodepends=("${subrodepends[@]}" "$KDECOREDEP $KDESUDEP $KDE3SUPPORTDEP")
+subrodepends=("${subrodepends[@]}" "$KDELIBS_COREDEP $KDESUDEP 
$KDE3SUPPORTDEP")
subgroups=("${subgroups[@]}" 'kde kde-core')
subarchs=("${subarchs[@]}" 'i686 x86_64 ppc')

subpkgs=("${subpkgs[@]}" "libkjsembed")
subdescs=("${subdescs[@]}" "ECMAScript bindings libraries.")
subdepends=("${subdepends[@]}" "$LIBQTUITOOLSDEP $LIBQTDBUSDEP bzip2 libx11 
$POLKIT_QT_1DEP")
-subrodepends=("${subrodepends[@]}" "$KDECOREDEP")
+subrodepends=("${subrodepends[@]}" "$KDELIBS_COREDEP")
subgroups=("${subgroups[@]}" 'kde kde-core')
subarchs=("${subarchs[@]}" 'i686 x86_64 ppc')

subpkgs=("${subpkgs[@]}" "libkutils")
subdescs=("${subdescs[@]}" "Utility library for printing, chatting and more.")
subdepends=("${subdepends[@]}" "$LIBQTDBUSDEP $LIBQTGUIDEP libxscrnsaver gamin 
xfsprogs-attr bzip2 $POLKIT_QT_1DEP")
-subrodepends=("${subrodepends[@]}" "$KDECOREDEP")
+subrodepends=("${subrodepends[@]}" "$KDELIBS_COREDEP")
subgroups=("${subgroups[@]}" 'kde kde-core')
subarchs=("${subarchs[@]}" 'i686 x86_64 ppc')

@@ -160,14 +160,14 @@ subarchs=("${subarchs[@]}" 'i686 x86_64 ppc')
subpkgs=("${subpkgs[@]}" "libkimgio")
subdescs=("${subdescs[@]}" "Gimgio class extension libraries.")
subdepends=("${subdepends[@]}" "$LIBQTGUIDEP $LIBQTDBUSDEP jasper libxext bzip2 
$POLKIT_QT_1DEP openexr>=1.6.1")
-subrodepends=("${subrodepends[@]}" "$KDECOREDEP")
+subrodepends=("${subrodepends[@]}" "$KDELIBS_COREDEP")
subgroups=("${subgroups[@]}" 'kde kde-core')
subarchs=("${subarchs[@]}" 'i686 x86_64 ppc')

subpkgs=("${subpkgs[@]}" "libkunitconversion")
subdescs=("${subdescs[@]}" "KDE Unit conversation library.")
subdepends=("${subdepends[@]}" "$LIBQTDBUSDEP $LIBQTGUIDEP bzip2 libxext 
$POLKIT_QT_1DEP")
-subrodepends=("${subrodepends[@]}" "$KDECOREDEP")
+subrodepends=("${subrodepends[@]}" "$KDELIBS_COREDEP")
subgroups=("${subgroups[@]}" 'kde kde-core')
subarchs=("${subarchs[@]}" 'i686 x86_64 ppc')

@@ -176,21 +176,21 @@ rodepends=("${rodepends[@]}" "${subpkgs[@]}")
subpkgs=("${subpkgs[@]}" "libkactivities")
subdescs=("${subdescs[@]}" "Libraries for the KDE activities management.")
subdepends=("${subdepends[@]}" "")
-subrodepends=("${subrodepends[@]}" "$KDECOREDEP")
+subrodepends=("${subrodepends[@]}" "$KDELIBS_COREDEP")
subgroups=("${subgroups[@]}" 'kde-extra')
subarchs=("${subarchs[@]}" 'i686 x86_64 ppc')

subpkgs=("${subpkgs[@]}" "libkdeclarative")
subdescs=("${subdescs[@]}" "KDE declarative extensions")
subdepends=("${subdepends[@]}" "$LIBQTDECLARATIVE")
-subrodepends=("${subrodepends[@]}" "$KDECOREDEP")
+subrodepends=("${subrodepends[@]}" "$KDELIBS_COREDEP")
subgroups=("${subgroups[@]}" 'kde-extra')
subarchs=("${subarchs[@]}" 'i686 x86_64 ppc')

subpkgs=("${subpkgs[@]}" "libnepomuk")
subdescs=("${subdescs[@]}" "Semantic information retrieval and tagging.")
subdepends=("${subdepends[@]}" "$LIBQTDBUSDEP $LIBQTGUIDEP 
soprano-backend-redland>=2.7.0 bzip2 $POLKIT_QT_1DEP libxext 
shared-desktop-ontologies")
-subrodepends=("${subrodepends[@]}" "$KDECOREDEP")
+subrodepends=("${subrodepends[@]}" "$KDELIBS_COREDEP")
subgroups=("${subgroups[@]}" 'kde-extra')
subarchs=("${subarchs[@]}" 'i686 x86_64 ppc')

@@ -203,7 +203,7 @@ _F_kde_subpkgs=("${subpkgs[@]}")
subpkgs=("${subpkgs[@]}" "ksgmltools2")
subdescs=("${subdescs[@]}" "KDE doc tools.")
subdepends=("${subdepends[@]}" "$LIBQTGUIDEP $LIBQTDBUSDEP docbook-xsl libxslt 
bzip2 gamin xfsprogs-attr libxext $POLKIT_QT_1DEP")
-subrodepends=("${subrodepends[@]}" "$KDECOREDEP")
+subrodepends=("${subrodepends[@]}" "$KDELIBS_COREDEP")
subgroups=("${subgroups[@]}" 'kde kde-core')
subarchs=("${subarchs[@]}" 'i686 x86_64 ppc')

@@ -211,7 +211,7 @@ subarchs=("${subarchs[@]}" 'i686 x86_64 ppc')
subpkgs=("${subpkgs[@]}" "$pkgname-interfaces")
subdescs=("${subdescs[@]}" "Kparts interface for text editors, mediaplayer and 
scripting.")
subdepends=("${subdepends[@]}" "gamin xfsprogs-attr bzip2 libxext 
$POLKIT_QT_1DEP $PHONONDEP")
-subrodepends=("${subrodepends[@]}" "$KDECOREDEP")
+subrodepends=("${subrodepends[@]}" "$KDELIBS_COREDEP")
subgroups=("${subgroups[@]}" 'kde kde-core')
subarchs=("${subarchs[@]}" 'i686 x86_64 ppc')

@@ -219,11 +219,11 @@ subarchs=("${subarchs[@]}" 'i686 x86_64 ppc')
subpkgs=("${subpkgs[@]}" "libkdesu")
subdescs=("${subdescs[@]}" "Library for password entering and handling.")
subdepends=("${subdepends[@]}" "$LIBQTDBUSDEP bzip2 $POLKIT_QT_1DEP")
-subrodepends=("${subrodepends[@]}" "$KDECOREDEP")
+subrodepends=("${subrodepends[@]}" "$KDELIBS_COREDEP")
subgroups=("${subgroups[@]}" 'kde kde-core')
subarchs=("${subarchs[@]}" 'i686 x86_64 ppc')

-######## libkdecore / libkdecore-data ###############
+######## kdelibs-core / kdelibs-data ###############
## projects in here:                               ##
## kinit , kdecore , kded , cmake , includes       ##
## kconf_update , kio , kioslave , interfaces/kio  ##
@@ -235,17 +235,17 @@ subarchs=("${subarchs[@]}" 'i686 x86_64 ppc')
## from here since these create weird circular depends() -- crazy -- ( KDE 4.4 )
## FIXME!!

-subpkgs=("${subpkgs[@]}" "libkdecore")
+subpkgs=("${subpkgs[@]}" "kdelibs-core")
subdescs=("${subdescs[@]}" "KDE4 Core Library.")
subdepends=("${subdepends[@]}" "$LIBQTNETWORKDEP pcre xz $POLKIT_QT_1DEP \
libdbusmenu-qt>=0.7.0 libgcc strigi>=0.7.2-2 xfsprogs-acl libxrender libice \
-       libxtst libxfixes libuuid libkrb5 shared-mime-info udev udisks upower")
-subrodepends=("${subrodepends[@]}" "libkdecore-data")
+       libxtst libxfixes libuuid libkrb5 shared-mime-info udev udisks upower 
attica>=0.1.2")
+subrodepends=("${subrodepends[@]}" "kdelibs-data")
subgroups=("${subgroups[@]}" 'kde kde-core')
subarchs=("${subarchs[@]}" 'i686 x86_64 ppc')

##FIXME!!! what to do with these ?
-subpkgs=("${subpkgs[@]}" "libkdecore-data")
+subpkgs=("${subpkgs[@]}" "kdelibs-data")
subdescs=("${subdescs[@]}" "Data files ( desktop files , protocol files , man , 
icons).")
subdepends=("${subdepends[@]}" "")
subrodepends=("${subrodepends[@]}" "")
@@ -269,21 +269,21 @@ subarchs=("${subarchs[@]}" 'i686 x86_64 ppc')
subpkgs=("${subpkgs[@]}" "sonnet-plugin-hspell")
subdescs=("${subdescs[@]}" "Natural language processing for hspell")
subdepends=("${subdepends[@]}" "$LIBQTDBUSDEP bzip2 $POLKIT_QT_1DEP hspell")
-subrodepends=("${subrodepends[@]}" "$KDECOREDEP")
+subrodepends=("${subrodepends[@]}" "$KDELIBS_COREDEP")
subgroups=("${subgroups[@]}" 'kde-extra')
subarchs=("${subarchs[@]}" 'i686 x86_64 ppc')

subpkgs=("${subpkgs[@]}" "sonnet-plugin-aspell")
subdescs=("${subdescs[@]}" "Natural language processing for aspell")
subdepends=("${subdepends[@]}" "$LIBQTDBUSDEP aspell bzip2 $POLKIT_QT_1DEP")
-subrodepends=("${subrodepends[@]}" "$KDECOREDEP")
+subrodepends=("${subrodepends[@]}" "$KDELIBS_COREDEP")
subgroups=("${subgroups[@]}" 'kde-extra')
subarchs=("${subarchs[@]}" 'i686 x86_64 ppc')

subpkgs=("${subpkgs[@]}" "sonnet-plugin-enchant")
subdescs=("${subdescs[@]}" "Natural language processing for enchant")
subdepends=("${subdepends[@]}" "$LIBQTDBUSDEP enchant bzip2 $POLKIT_QT_1DEP")
-subrodepends=("${subrodepends[@]}" "$KDECOREDEP")
+subrodepends=("${subrodepends[@]}" "$KDELIBS_COREDEP")
subgroups=("${subgroups[@]}" 'kde-extra')
subarchs=("${subarchs[@]}" 'i686 x86_64 ppc')

@@ -317,7 +317,7 @@ build()
KDE_project_install  interfaces/terminal
Fsplit $pkgname-interfaces /\*

-       #####  likdecore / libkdecore-data start  #######
+       #####  kdelibs-core / kdelibs-data start  #######
KDE_project_install kdecore
KDE_project_install kinit
KDE_project_install kded
@@ -343,17 +343,17 @@ build()

KDE_cleanup

-       Fsplit libkdecore-data usr/share/apps/kdeui/about
-       Fsplit libkdecore-data usr/share/apps/kdeui/pics
-       Fsplit libkdecore-data usr/share/kde4/services
-       Fsplit libkdecore-data usr/share/kde4/servicetypes
-       Fsplit libkdecore-data usr/share/apps/LICENSES
-       Fsplit libkdecore-data etc/kde/config/colors
-       Fsplit libkdecore-data etc/xdg/menus
-       Fsplit libkdecore-data usr/share/man
-
-       ## now split the rest to libkdecore
-       Fsplit libkdecore /\*
+       Fsplit kdelibs-data usr/share/apps/kdeui/about
+       Fsplit kdelibs-data usr/share/apps/kdeui/pics
+       Fsplit kdelibs-data usr/share/kde4/services
+       Fsplit kdelibs-data usr/share/kde4/servicetypes
+       Fsplit kdelibs-data usr/share/apps/LICENSES
+       Fsplit kdelibs-data etc/kde/config/colors
+       Fsplit kdelibs-data etc/xdg/menus
+       Fsplit kdelibs-data usr/share/man
+
+       ## now split the rest to kdelibs-core
+       Fsplit kdelibs-core /\*

KDE_install
}
_______________________________________________
Frugalware-git mailing list
Frugalware-git@frugalware.org
http://frugalware.org/mailman/listinfo/frugalware-git

Reply via email to