Git-Url: 
http://git.frugalware.org/gitweb/gitweb.cgi?p=frugalware-current.git;a=commitdiff;h=10ab151d14bc0970913bd5104c87f207015dca75

commit 10ab151d14bc0970913bd5104c87f207015dca75
Author: Devil505 <devil505li...@gmail.com>
Date:   Mon Oct 17 20:45:31 2011 +0200

xfce4-indicator-plugin-0.3.1-2-i686
* bin, since we don't have indicators anymore

diff --git 
a/source/xfce4-extra/xfce4-indicator-plugin/01_search-for-indicator-0.4-pc.patch
 
b/source/xfce4-extra/xfce4-indicator-plugin/01_search-for-indicator-0.4-pc.patch
deleted file mode 100644
index 5451a6c..0000000
--- 
a/source/xfce4-extra/xfce4-indicator-plugin/01_search-for-indicator-0.4-pc.patch
+++ /dev/null
@@ -1,97 +0,0 @@
-Search for the renamed libindicator .pc file
-
---- xfce4-indicator-plugin-0.2.1.orig/configure.in
-+++ xfce4-indicator-plugin-0.2.1/configure.in
-@@ -69,7 +69,7 @@ dnl ***********************************
- XDT_CHECK_PACKAGE([GTK], [gtk+-2.0], [2.6.0])
- XDT_CHECK_PACKAGE([LIBXFCE4UTIL], [libxfce4util-1.0], [4.3.99.2])
- XDT_CHECK_PACKAGE([LIBXFCE4PANEL], [libxfce4panel-1.0], [4.3.99.2])
--XDT_CHECK_PACKAGE([INDICATOR], [indicator], [0.3.0])
-+XDT_CHECK_PACKAGE([INDICATOR], [indicator-0.4], [0.3.0])
-
- dnl ***********************************
- dnl *** Check for debugging support ***
-@@ -79,8 +79,8 @@ XDT_FEATURE_DEBUG()
- dnl ***********************
- dnl *** Indicator info ***
- dnl ***********************
--INDICATORDIR=`$PKG_CONFIG --variable=indicatordir indicator`
--INDICATORICONSDIR=`$PKG_CONFIG --variable=iconsdir indicator`
-+INDICATORDIR=`$PKG_CONFIG --variable=indicatordir indicator-0.4`
-+INDICATORICONSDIR=`$PKG_CONFIG --variable=iconsdir indicator-0.4`
-
- AC_SUBST(INDICATORDIR)
- AC_SUBST(INDICATORICONSDIR)
---- xfce4-indicator-plugin-0.2.1.orig/configure
-+++ xfce4-indicator-plugin-0.2.1/configure
-@@ -13245,22 +13245,22 @@ $as_echo "$xdt_cv_PKG_CONFIG_VERSION" >&
-   fi
-
-
--  { $as_echo "$as_me:${as_lineno-$LINENO}: checking for indicator >= 0.3.0" 
>&5
--$as_echo_n "checking for indicator >= 0.3.0... " >&6; }
--  if $PKG_CONFIG "--atleast-version=0.3.0" "indicator" >/dev/null 2>&1; then
--    INDICATOR_VERSION=`$PKG_CONFIG --modversion "indicator"`
-+  { $as_echo "$as_me:${as_lineno-$LINENO}: checking for indicator-0.4 >= 
0.3.0" >&5
-+$as_echo_n "checking for indicator-0.4 >= 0.3.0... " >&6; }
-+  if $PKG_CONFIG "--atleast-version=0.3.0" "indicator-0.4" >/dev/null 2>&1; 
then
-+    INDICATOR_VERSION=`$PKG_CONFIG --modversion "indicator-0.4"`
-     { $as_echo "$as_me:${as_lineno-$LINENO}: result: $INDICATOR_VERSION" >&5
- $as_echo "$INDICATOR_VERSION" >&6; }
-
-     { $as_echo "$as_me:${as_lineno-$LINENO}: checking INDICATOR_CFLAGS" >&5
- $as_echo_n "checking INDICATOR_CFLAGS... " >&6; }
--    INDICATOR_CFLAGS=`$PKG_CONFIG --cflags "indicator"`
-+    INDICATOR_CFLAGS=`$PKG_CONFIG --cflags "indicator-0.4"`
-     { $as_echo "$as_me:${as_lineno-$LINENO}: result: $INDICATOR_CFLAGS" >&5
- $as_echo "$INDICATOR_CFLAGS" >&6; }
-
-     { $as_echo "$as_me:${as_lineno-$LINENO}: checking INDICATOR_LIBS" >&5
- $as_echo_n "checking INDICATOR_LIBS... " >&6; }
--    INDICATOR_LIBS=`$PKG_CONFIG --libs "indicator"`
-+    INDICATOR_LIBS=`$PKG_CONFIG --libs "indicator-0.4"`
-     { $as_echo "$as_me:${as_lineno-$LINENO}: result: $INDICATOR_LIBS" >&5
- $as_echo "$INDICATOR_LIBS" >&6; }
-
-@@ -13272,15 +13272,15 @@ $as_echo "$INDICATOR_LIBS" >&6; }
-
-
-
--  elif $PKG_CONFIG --exists "indicator" >/dev/null 2>&1; then
--    xdt_cv_version=`$PKG_CONFIG --modversion "indicator"`
-+  elif $PKG_CONFIG --exists "indicator-0.4" >/dev/null 2>&1; then
-+    xdt_cv_version=`$PKG_CONFIG --modversion "indicator-0.4"`
-     { $as_echo "$as_me:${as_lineno-$LINENO}: result: found, but 
$xdt_cv_version" >&5
- $as_echo "found, but $xdt_cv_version" >&6; }
-
-
--      echo "*** The required package indicator was found on your system,"
-+      echo "*** The required package indicator-0.4 was found on your system,"
-       echo "*** but the installed version ($xdt_cv_version) is too old."
--      echo "*** Please upgrade indicator to atleast version 0.3.0, or adjust"
-+      echo "*** Please upgrade indicator-0.4 to atleast version 0.3.0, or 
adjust"
-       echo "*** the PKG_CONFIG_PATH environment variable if you installed"
-       echo "*** the new version of the package in a nonstandard prefix so"
-       echo "*** pkg-config is able to find it."
-@@ -13291,8 +13291,8 @@ $as_echo "found, but $xdt_cv_version" >&
- $as_echo "not found" >&6; }
-
-
--      echo "*** The required package indicator was not found on your system."
--      echo "*** Please install indicator (atleast version 0.3.0) or adjust"
-+      echo "*** The required package indicator-0.4 was not found on your 
system."
-+      echo "*** Please install indicator-0.4 (atleast version 0.3.0) or 
adjust"
-       echo "*** the PKG_CONFIG_PATH environment variable if you"
-       echo "*** installed the package in a nonstandard prefix so that"
-       echo "*** pkg-config is able to find it."
-@@ -13390,8 +13390,8 @@ $as_echo "minimum" >&6; }
-   fi
-
-
--INDICATORDIR=`$PKG_CONFIG --variable=indicatordir indicator`
--INDICATORICONSDIR=`$PKG_CONFIG --variable=iconsdir indicator`
-+INDICATORDIR=`$PKG_CONFIG --variable=indicatordir indicator-0.4`
-+INDICATORICONSDIR=`$PKG_CONFIG --variable=iconsdir indicator-0.4`
-
-
-
diff --git 
a/source/xfce4-extra/xfce4-indicator-plugin/02_fix-menu-position.patch 
b/source/xfce4-extra/xfce4-indicator-plugin/02_fix-menu-position.patch
deleted file mode 100644
index a479d69..0000000
--- a/source/xfce4-extra/xfce4-indicator-plugin/02_fix-menu-position.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 4c410464a89615547e959c0392c69c77add4eaf5 Mon Sep 17 00:00:00 2001
-From: Mark Trompell <m...@foresightlinux.org>
-Date: Tue, 19 Jul 2011 06:47:21 +0000
-Subject: fix menu position
-
----
-diff --git a/panel-plugin/indicator.c b/panel-plugin/indicator.c
-index 1741a9c..4468a52 100644
---- a/panel-plugin/indicator.c
-+++ b/panel-plugin/indicator.c
-@@ -163,14 +163,12 @@ on_button_press (GtkWidget *widget, GdkEventButton 
*event, IndicatorPlugin *indi
-   {
-     if( event->button == 1) /* left click only */
-     {
--      gtk_menu_popup (GTK_MENU(g_object_get_data (G_OBJECT(widget),"menu")), 
NULL,
--                      NULL, NULL, NULL, 1, event->time);
--      /* no approvement to the above */
--      /*
--      gtk_menu_popup (GTK_MENU(g_object_get_data (G_OBJECT(widget),"menu")), 
NULL, NULL,
-+      GtkMenu * menu = GTK_MENU(g_object_get_data (G_OBJECT(widget),"menu"));
-+      gtk_menu_attach_to_widget(menu, widget, NULL);
-+      gtk_menu_popup (menu, NULL, NULL,
-                       xfce_panel_plugin_position_menu,
-                       indicator->plugin, 1, gtk_get_current_event_time ());
--      */
-+
-       return TRUE;
-     }
-     /* event doesn't make it to the ebox, so I just push it. */
---
-cgit
diff --git 
a/source/xfce4-extra/xfce4-indicator-plugin/03_attach-button-to-menu-right-at-the-beginning.patch
 
b/source/xfce4-extra/xfce4-indicator-plugin/03_attach-button-to-menu-right-at-the-beginning.patch
deleted file mode 100644
index 7bda470..0000000
--- 
a/source/xfce4-extra/xfce4-indicator-plugin/03_attach-button-to-menu-right-at-the-beginning.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From defca954a995cba535ece42ae2a890ea0fdb3f10 Mon Sep 17 00:00:00 2001
-From: Mark Trompell <m...@foresightlinux.org>
-Date: Tue, 19 Jul 2011 07:00:00 +0000
-Subject: attach button to menu right at the beginning
-
----
-diff --git a/panel-plugin/indicator.c b/panel-plugin/indicator.c
-index 4468a52..613c1a5 100644
---- a/panel-plugin/indicator.c
-+++ b/panel-plugin/indicator.c
-@@ -163,9 +163,7 @@ on_button_press (GtkWidget *widget, GdkEventButton *event, 
IndicatorPlugin *indi
-   {
-     if( event->button == 1) /* left click only */
-     {
--      GtkMenu * menu = GTK_MENU(g_object_get_data (G_OBJECT(widget),"menu"));
--      gtk_menu_attach_to_widget(menu, widget, NULL);
--      gtk_menu_popup (menu, NULL, NULL,
-+      gtk_menu_popup (GTK_MENU(g_object_get_data (G_OBJECT(widget),"menu")), 
NULL, NULL,
-                       xfce_panel_plugin_position_menu,
-                       indicator->plugin, 1, gtk_get_current_event_time ());
-
-@@ -234,7 +232,10 @@ entry_added (IndicatorObject * io, IndicatorObjectEntry * 
entry, gpointer user_d
-     gtk_button_set_label(GTK_BUTTON(button), gtk_label_get_label 
(entry->label));
-
-   if (entry->menu != NULL)
-+  {
-     g_object_set_data(G_OBJECT(button), "menu", entry->menu);
-+    gtk_menu_attach_to_widget(entry->menu, button, NULL);
-+  }
-
-   g_signal_connect(button, "button-press-event", G_CALLBACK(on_button_press),
-                    user_data);
---
-cgit
diff --git a/source/xfce4-extra/xfce4-indicator-plugin/FrugalBuild 
b/source/xfce4-extra/xfce4-indicator-plugin/FrugalBuild
deleted file mode 100644
index 8603ba2..0000000
--- a/source/xfce4-extra/xfce4-indicator-plugin/FrugalBuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Compiling Time: 0.05 SBU
-# Maintainer: Devil505 <devil505li...@gmail.com>
-
-pkgname=xfce4-indicator-plugin
-pkgver=0.3.1
-pkgrel=2
-pkgdesc="A plugin to display information from Ubuntu's MessagingMenu."
-url="http://goodies.xfce.org/projects/panel-plugins/xfce4-indicator-plugin";
-makedepends=('intltool')
-depends=('libxfcegui4>=4.8.0' 'xfce4-panel>=4.8.0' 'libxfce4util>=4.8.0' 
'libindicator>=0.4')
-groups=('xfce4-extra' 'xfce4-goodies')
-_F_gnome_iconcache="y"
-_F_xfce_category="panel-plugins"
-Finclude xfce4 gnome-scriptlet
-archs=('i686' 'x86_64')
-source=($source 01_search-for-indicator-0.4-pc.patch \
-       02_fix-menu-position.patch \
-       03_attach-button-to-menu-right-at-the-beginning.patch)
-sha1sums=('45eece0519f5a8efcb6b8c5f5a9bc096ef310a23' \
-          '097c6485d3bce96a88a415919f5d16efa69a1853' \
-          '5702f2981a63d2c61f03cbdafeb0a0b32bf7c285' \
-          '7b7d18da48149215f0b9153e72bc8ddadc6d3c26')
-
-# optimization OK
-
_______________________________________________
Frugalware-git mailing list
Frugalware-git@frugalware.org
http://frugalware.org/mailman/listinfo/frugalware-git

Reply via email to