Git-Url: 
http://git.frugalware.org/gitweb/gitweb.cgi?p=frugalware-current.git;a=commitdiff;h=2ece73712d44dca9e5129e0378afe58093fe7ed7

commit 2ece73712d44dca9e5129e0378afe58093fe7ed7
Author: Miklos Vajna <vmik...@frugalware.org>
Date:   Fri Oct 21 21:49:00 2011 +0200

qosmic-1.4.9pre-1-i686

- util-linux-ng -> util-linux

diff --git a/source/xapps-extra/qosmic/FrugalBuild 
b/source/xapps-extra/qosmic/FrugalBuild
index 9d12d7f..c90aea3 100644
--- a/source/xapps-extra/qosmic/FrugalBuild
+++ b/source/xapps-extra/qosmic/FrugalBuild
@@ -3,20 +3,22 @@
# Contributor: Othmane Benkirane <e...@rhyhann.net>

pkgname=qosmic
-pkgver=1.4.8
-pkgrel=3
+pkgver=1.4.9pre
+pkgrel=1
pkgdesc="A cosmic recursive flame fractal editor that uses flam3 and Qt4"
-depends=('libqtgui>=4.6.2-3' 'util-linux-ng' 'lua' 'flam3>=2.7.18-3')
+depends=('libqtgui>=4.6.2-3' 'util-linux' 'lua' 'flam3>=2.7.18-3' 'libqtxml' 
'libqtuitools')
groups=('xapps-extra')
archs=('i686' 'x86_64')
_F_googlecode_ext=".tar.bz2"
-Finclude googlecode
+_F_scm_type=subversion
+_F_scm_url=http://qosmic.googlecode.com/svn/trunk/qosmic
+_F_scm_tag=33
+Finclude googlecode scm
_F_conf_configure="./build.sh"
-source=(${source[@]} $pkgname-pro.patch)
-sha1sums=('3a97144df09813925760338db100f0c52ba8dd74' \
-          '56cab3605337709ea8085a8f75c035aa83440e55')
-
+unset source
build() {
+  Funpack_scm
+  Fsed 'PALETTESDIR = $$FLAM3_SRC_DIR' 'PALETTESDIR = /usr/share/flam3' 
qosmic.pro
Fmake
make INSTALL_ROOT=$Fdestdir install || Fdie
}
diff --git a/source/xapps-extra/qosmic/qosmic-pro.patch 
b/source/xapps-extra/qosmic/qosmic-pro.patch
deleted file mode 100644
index 43f7122..0000000
--- a/source/xapps-extra/qosmic/qosmic-pro.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff -aur qosmic-1.4.8/qosmic.pro qosmic-1.4.8-2/qosmic.pro
---- qosmic-1.4.8/qosmic.pro    2009-12-15 16:10:36.000000000 -0600
-+++ qosmic-1.4.8-2/qosmic.pro  2010-05-06 10:03:29.000000000 -0500
-@@ -90,10 +90,10 @@
- }
-
- link_pkgconfig {
--      ! system(pkg-config --atleast-version 2.7.18 flam3) {
-+      system(pkg-config --atleast-version 2.7.18 flam3) {
-               error("Qosmic $$VERSION requires at least version 2.7.18 of 
flam3 to build.")
-       }
--      ! system(pkg-config --max-version 2.7.9999 flam3) {
-+      system(pkg-config --max-version 2.7.9999 flam3) {
-               error("Qosmic $$VERSION is not compatible with flam3 versions 
>=2.8")
-       }
- }
_______________________________________________
Frugalware-git mailing list
Frugalware-git@frugalware.org
http://frugalware.org/mailman/listinfo/frugalware-git

Reply via email to