Git-Url: 
http://git.frugalware.org/gitweb/gitweb.cgi?p=xfcetesting.git;a=commitdiff;h=15d43398b35b26e0a7f1eebfa44ebc96760291b9

commit 15d43398b35b26e0a7f1eebfa44ebc96760291b9
Author: bouleetbil <bouleet...@frogdev.info>
Date:   Fri Jan 14 00:07:27 2011 +0100

gconf-2.32.1-1-x86_64

*Version bump

diff --git a/source/gnome/gconf/FrugalBuild b/source/gnome/gconf/FrugalBuild
index 87ace55..9c7a59f 100644
--- a/source/gnome/gconf/FrugalBuild
+++ b/source/gnome/gconf/FrugalBuild
@@ -4,8 +4,8 @@

pkgname=gconf
_F_gnome_name=GConf
-pkgver=2.32.0
-pkgrel=2
+pkgver=2.32.1
+pkgrel=1
pkgdesc="A configuration database system for GNOME"
url="http://www.gnome.org/";
depends=('orbit2>=2.14.18' 'libxml2' 'dbus-glib' 'polkit>=0.99')
@@ -13,10 +13,9 @@ makedepends=('indent' 'gtk-doc>=1.11' 'openldap>=2.4.16' 
'perl-xml-parser' 'intl
groups=('gnome' 'gnome-minimal')
archs=('i686' 'x86_64' 'ppc')
Finclude gnome
-source=(${source[@]} gconf-2.16.0-reload.patch gtk3.diff)
-sha1sums=('2711c7b53761d2c789112bb1f989f1c1a6de5265' \
-          'c51bd437b495af6b25aff143a45c0b93a4afc236' \
-          '9ab1e26a03254b75fb2243402581bc772d2da1d8')
+source=(${source[@]} gconf-2.16.0-reload.patch)
+sha1sums=('8d8d113dc654314cf955c4f8c5a4cccd3a15f447' \
+          'c51bd437b495af6b25aff143a45c0b93a4afc236')

Fconfopts="${Fconfopts[@]}  --with-gtk=3.0"
subpkgs=('gconf-ldap')
diff --git a/source/gnome/gconf/gtk3.diff b/source/gnome/gconf/gtk3.diff
deleted file mode 100644
index 7c49117..0000000
--- a/source/gnome/gconf/gtk3.diff
+++ /dev/null
@@ -1,60 +0,0 @@
-From d1040d83beefa492499b882f13ced971d0292d7b Mon Sep 17 00:00:00 2001
-From: Matthias Clasen <mcla...@redhat.com>
-Date: Sun, 03 Oct 2010 15:11:40 +0000
-Subject: Allow building against GTK+ 3
-
-This adds the common --with-gtk option to configure. The default
-is to build against GTK+ 3.
----
-diff --git a/configure.in b/configure.in
-index 70274b7..9a67c68 100644
---- a/configure.in
-+++ b/configure.in
-@@ -139,6 +139,25 @@ fi
-
- GTK_DOC_CHECK([1.0])
-
-+AC_MSG_CHECKING([which gtk+ version to compile against])
-+AC_ARG_WITH([gtk],
-+  [AS_HELP_STRING([--with-gtk=2.0|3.0],[which gtk+ version to compile against 
(default: 3.0)])],
-+  [case "$with_gtk" in
-+     2.0|3.0) ;;
-+     *) AC_MSG_ERROR([invalid gtk version specified]) ;;
-+   esac],
-+  [with_gtk=3.0])
-+AC_MSG_RESULT([$with_gtk])
-+
-+case "$with_gtk" in
-+  2.0) GTK_API_VERSION=2.0
-+       GTK_REQUIRED=2.14
-+       ;;
-+  3.0) GTK_API_VERSION=3.0
-+       GTK_REQUIRED=2.90
-+       ;;
-+esac
-+
- AC_ARG_ENABLE(gtk,
-   AS_HELP_STRING([--enable-gtk],
-     [Enable GTK+ support (for gconf-sanity-check) @<:@default=auto@:>@]),
-@@ -146,8 +165,8 @@ AC_ARG_ENABLE(gtk,
-
- PKGCONFIG_MODULES='glib-2.0 > 2.14.0 gio-2.0 >= 2.25.9 gthread-2.0 
gmodule-2.0 >= 2.7.0 gobject-2.0 >= 2.7.0 ORBit-2.0 >= 2.4.0'
- PKGCONFIG_MODULES_WITH_XML="$PKGCONFIG_MODULES libxml-2.0"
--PKGCONFIG_MODULES_WITH_GTK=" $PKGCONFIG_MODULES gtk+-2.0 >= 2.14.0"
--PKGCONFIG_MODULES_WITH_XML_AND_GTK=" $PKGCONFIG_MODULES gtk+-2.0 libxml-2.0"
-+PKGCONFIG_MODULES_WITH_GTK=" $PKGCONFIG_MODULES gtk+-$GTK_API_VERSION >= 
$GTK_REQUIRED"
-+PKGCONFIG_MODULES_WITH_XML_AND_GTK=" $PKGCONFIG_MODULES gtk+-$GTK_API_VERSION 
>= $GTK_REQUIRED libxml-2.0"
- PKGCONFIG_MODULES_DBUS=" dbus-1 >= 1.0.0 dbus-glib-1 >= 0.74"
-
- PKG_CHECK_MODULES(DEPENDENT, $PKGCONFIG_MODULES)
-@@ -159,7 +178,7 @@ if test "x$enable_gtk" != "xno"; then
-
-   if test "x$enable_gtk" = "xyes" && test "x$HAVE_GTK" = "xno"; then
-     AC_MSG_ERROR([[
--*** Could not find GTK+ 2.14 or greater.
-+*** Could not find GTK+ $GTK_REQUIRED.
- *** Go to http://www.gtk.org/ to get it.]])
-   fi
- else
---
-cgit v0.8.3.1
_______________________________________________
Frugalware-git mailing list
Frugalware-git@frugalware.org
http://frugalware.org/mailman/listinfo/frugalware-git

Reply via email to