On Fri, Oct 05, 2007 at 09:23:10PM +0000, David Holroyd wrote:
> I've just checked out revision 582391 and I get 1 error from 'mvn test':
> 
> testExceptionDuringRenameEnd(org.apache.ftpserver.ftplet.FtpLetThrowIOExceptionTest)
>   Time elapsed: 0.159 sec  <<< ERROR!
> org.apache.commons.net.ftp.FTPConnectionClosedException: Connection closed 
> without indication.
>         at org.apache.commons.net.ftp.FTP.__getReply(FTP.java:267)
>         at org.apache.commons.net.ftp.FTP.sendCommand(FTP.java:460)
>         at org.apache.commons.net.ftp.FTP.sendCommand(FTP.java:520)
>         at org.apache.commons.net.ftp.FTP.rnto(FTP.java:1173)
>         at org.apache.commons.net.ftp.FTPClient.rename(FTPClient.java:1714)
>         at 
> org.apache.ftpserver.ftplet.FtpLetReturnDisconnectTest.testExceptionDuringRenameEnd(FtpLetReturnDisconnectTest.java:286)

but the test passes when I run it in Eclipse.  Odd.

It also passes when I do a 'mvn test' within the 'core' module (the
first time I tried at the top level).

...

And now it works when I try at the top level!  Hmm.  Maybe I or Maven
are just having a bad day.  Sorry for the noise.


-- 
http://david.holroyd.me.uk/

Reply via email to