=====[ Tempest Security Intelligence - ADV-21/2018 ]===

Rapid Scada - 5.5.0 - Insecure Permissions
-------------------------------------------------------
Author:
- Filipe Xavier Oliveira: < filipe.xavier () tempest.com.br

=====[ Table of Contents
]=====================================================

* Overview
* Detailed description
* Timeline of disclosure
* Thanks & Acknowledgements
* References

=====[ Overview
]==============================================================

* System affected : Rapid Scada [1]
* Software Version : 5.5.0. Other versions or models may also be affected.
* Impact : A malware could overwrite originals files to do persistence
or elevate privileges, because the installation folder gives full access
to any user on the system.

=====[ Detailed description
]==================================================

A vulnerability allows local attackers to escalate privilege on Rapid
Scada 5.5.0 because of weak C:\SCADA permissions. The specific flaw
exists within the access control that is set and modified during the
installation of the product. The product sets weak access control
restrictions. An attacker can leverage this vulnerability to execute
arbitrary code under the context of Administrator, the IUSR account, or
SYSTEM.

C:\>icacls SCADA
SCADA BUILTIN\Administrators:(I)(F)
      BUILTIN\Administrators:(I)(OI)(CI)(IO)(F)
      NT AUTHORITY\SYSTEM:(I)(F)
      NT AUTHORITY\SYSTEM:(I)(OI)(CI)(IO)(F)
      BUILTIN\Users:(I)(OI)(CI)(RX)
      NT AUTHORITY\Authenticated Users:(I)(M)
      NT AUTHORITY\Authenticated Users:(I)(OI)(CI)(IO)(M)

=====[ Timeline of disclosure
]===============================================

01/09/2018 - Vendor was informed of the vulnerability.
01/15/2018 - Vendor told us that will not focus on this vulnerability
for now.
02/09/2018 - CVE assigned [2]
03/05/2018 - Advisory publication date.

=====[ Thanks & Acknowledgements
]============================================

- Tempest Security Intelligence / Tempest's Pentest Team [3]

=====[ References
]===========================================================

[1] - http://rapidscada.org/
[2] - https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-5313
[3] - http://www.tempest.com.br/

-- 
Filipe Oliveira
Tempest Security Intelligence

=====[ Tempest Security Intelligence - ADV-21/2018 ]===

Rapid Scada - 5.5.0 - Insecure Permissions
-------------------------------------------------------
Author:
- Filipe Xavier Oliveira: < filipe.xavier () tempest.com.br

=====[ Table of Contents ]=====================================================

* Overview
* Detailed description
* Timeline of disclosure
* Thanks & Acknowledgements
* References

=====[ Overview ]==============================================================

* System affected : Rapid Scada [1]
* Software Version : 5.5.0. Other versions or models may also be affected.
* Impact : A malware could overwrite originals files to do persistence or 
elevate privileges, because the installation folder gives full access to any 
user on the system.

=====[ Detailed description ]==================================================

A vulnerability allows local attackers to escalate privilege on Rapid Scada 
5.5.0 because of weak C:\SCADA permissions. The specific flaw exists within the 
access control that is set and modified during the installation of the product. 
The product sets weak access control restrictions. An attacker can leverage 
this vulnerability to execute arbitrary code under the context of 
Administrator, the IUSR account, or SYSTEM.

C:\>icacls SCADA
SCADA BUILTIN\Administrators:(I)(F)
      BUILTIN\Administrators:(I)(OI)(CI)(IO)(F)
      NT AUTHORITY\SYSTEM:(I)(F)
      NT AUTHORITY\SYSTEM:(I)(OI)(CI)(IO)(F)
      BUILTIN\Users:(I)(OI)(CI)(RX)
      NT AUTHORITY\Authenticated Users:(I)(M)
      NT AUTHORITY\Authenticated Users:(I)(OI)(CI)(IO)(M)

=====[ Timeline of disclosure ]===============================================

01/09/2018 - Vendor was informed of the vulnerability.
01/15/2018 - Vendor told us that will not focus on this vulnerability for now.
02/09/2018 - CVE assigned [2]
03/05/2018 - Advisory publication date.

=====[ Thanks & Acknowledgements ]============================================

- Tempest Security Intelligence / Tempest's Pentest Team [3]

=====[ References ]===========================================================

[1] - http://rapidscada.org/
[2] - https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-5313
[3] http://www.tempest.com.br/
_______________________________________________
Sent through the Full Disclosure mailing list
https://nmap.org/mailman/listinfo/fulldisclosure
Web Archives & RSS: http://seclists.org/fulldisclosure/

Reply via email to