On Thu, Jul 22, 2021 at 03:34:56PM -0400, John Sellens wrote:
> When I have the vim editor open in an xterm window, in insert mode,
> and move my mouse (and focus) into another window, the vim in the
> original window receives some sort of escape sequence that causes
> it to leave insert mode and beep.

You presumably have some sort of vim plugin installed causing this.  There's
nothing that fvwm is going to be doing to make vim in xterm (or any other
terminal emulator) come out of insert mode.  The only way it could is if fvwm
was using FakeKeyPress, but this hasn't worked in years due to most
applications not allowing synthetic key events due to security considerations.

> I tried starting vim without customization, and fvwm 2.6.8 and fvwm 3 with
> stock configuration.  It seems to happen in xterm, x-terminal-emumator,
> terminator, uxterm, but not in rxvt.  I'm on ubuntu 21.04.

Can you share your fvwm configuration?  I know you've said it happend with
"stock configuration", but I can't reproduce the problem doing just that with


Reply via email to