>> Hey Simon, >> I had this discussion back in the day with Gavin, and at the time, >> there was little bandwidth to take on/ enforce this type of >> cross-component requirement. >> >> I would also be interested in aiding you in this endeavor in a minimal way. >> >> * Review the existing 'defaults' proposal by Gavin that partially >> addresses this issue (by allowing each component 'defaults') >> >> The idea of any outside files (ini or otherwise) influencing components >> indirectly is a BAD idea in my opinion, and I think that was a proposed >> route. In order of precedence of goals, I place "use-at-will >> architecture" higher than "configuration over convention" even though I >> value both very highly. Having a zendframework.ini that components >> globally know about introduces coupling (at the component level) that I >> simply cannot agree with. > >I agree. > ditto!
>What I would like to see is that any component that takes an array of >options also accepts a Zend_Config object (of the right level). i.e. >internally, the component would just use $config->optionItem1 directly >and it's the developer's responsibility to pass the right "sub object" >part of the full Zend_Config object to the component. > >(I hope that makes sense!) Perfect sense and I agree. For instance, Zend_Db::factory($config->db->adapter_type, $config->db->toArray()); could be simplified in this way Zend_Db::factory($config->db->adapter_type, $config->db); or Zend_Db::factory($config->db); Jordan
