Bugs item #1596466, was opened at 2006-11-14 11:08
Message generated for change (Comment added) made by deckrider
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=100235&aid=1596466&group_id=235

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: None
Group: 2.0.0 beta 6
Status: Open
Resolution: None
Priority: 5
Private: No
Submitted By: Mad Druid (maddruid)
Assigned to: Christopher (siege) O'Brien (taliesein)
Summary: Quotes and gt/lt printed as HTML entities in Meanwhile conv

Initial Comment:
I am running gaim 2.0.0 beta 4 and I use it daily in a conference with my 
co-workers. We start a conference every morning and use it as a way to keep in 
touch (we are in different parts of the country). I'm not sure which version it 
started with, but any time you type a quotation mark or a greater than or a 
less than symbol, what gets printed in the conference is " < or > 
This does not happen when you have an individual meanwhile chat with someone. 
If you need more information, please let me know.

----------------------------------------------------------------------

Comment By: David Everly (deckrider)
Date: 2007-02-09 09:10

Message:
Logged In: YES 
user_id=1113403
Originator: NO

Forgot to say that my test was on Debian GNU/Linux (Etch).

----------------------------------------------------------------------

Comment By: Mad Druid (maddruid)
Date: 2007-02-09 08:49

Message:
Logged In: YES 
user_id=1488257
Originator: YES

I just tested the patch on windows as well and it works great!  I tested
<, >, &, ", and shift-enter.  No HTML, no html entities.

----------------------------------------------------------------------

Comment By: David Everly (deckrider)
Date: 2007-02-09 08:44

Message:
Logged In: YES 
user_id=1113403
Originator: NO

I finally had the opportunity to test this patch and it works for me!

----------------------------------------------------------------------

Comment By: Stu Tomlinson (nosnilmot)
Date: 2007-02-09 05:36

Message:
Logged In: YES 
user_id=309779
Originator: NO

It is indeed intended that the core sends html to prpls now, see:
http://svn.sourceforge.net/viewvc/gaim?view=rev&revision=14518

sorry I obviously didn't get the sametime adjustments correct (as I
suspected in my commit message).

----------------------------------------------------------------------

Comment By: Christopher (siege) O'Brien (taliesein)
Date: 2007-02-08 23:15

Message:
Logged In: YES 
user_id=77326
Originator: NO

I'd thrown in some stripping code (incorrectly), but the problem is really
that the GaimConvesation is sending HTML formatting to the conversation at
all; it should only allow and send on plain-text. I think I may have fixed
this by adjusting the conversation flags immediately after creation, and
I'm testing it out.

----------------------------------------------------------------------

Comment By: Mad Druid (maddruid)
Date: 2007-02-08 21:59

Message:
Logged In: YES 
user_id=1488257
Originator: YES

I got the libsametime.dll compiled in windows, but surprisingly, I can't
find anyone at work to test a conference with me at midnight.  I'll try it
in the morning and report back to the ticket.  Thanks for the patch.

----------------------------------------------------------------------

Comment By: Mad Druid (maddruid)
Date: 2007-02-08 20:37

Message:
Logged In: YES 
user_id=1488257
Originator: YES

Changed category to None.

----------------------------------------------------------------------

Comment By: David Everly (deckrider)
Date: 2007-02-08 20:25

Message:
Logged In: YES 
user_id=1113403
Originator: NO

By the way, I disagree with the category=win32...it happens on linux also,
both beta5 and beta6 at least.

----------------------------------------------------------------------

Comment By: David Everly (deckrider)
Date: 2007-02-08 20:20

Message:
Logged In: YES 
user_id=1113403
Originator: NO

I've uploaded patch 1655707 to address this (untested as of yet, but will
report back when I can access a sametime/meanwhile server tomorrow):

https://sourceforge.net/tracker/index.php?func=detail&aid=1655707&group_id=235&atid=300235

----------------------------------------------------------------------

Comment By: Mad Druid (maddruid)
Date: 2007-01-29 13:33

Message:
Logged In: YES 
user_id=1488257
Originator: YES

Also discovered today thath the underscore symbol gets converted to <U>
</U>.  I pasted the following URL into the conference today:

http://www.microsoft-watch.com/content/vista/tmobile_offers_vista_users_free_wifi_at_its_hotspots.html

It was converted to this when it was displayed:


http://www.microsoft-watch.com/content/vista/tmobile<U>offers</U>vista<U>users</U>free<U>wifi</U>at<U>its</U>hotspots.html

However, the following text that I input:

<>&"_

Displays this:

&lt;&gt;&amp;&quot;_

So it looks like the underscore only gets converted sometimes. Maybe when
it's part of a word. If I type _hello_ into the window, it gets displayed
as:

<U>hello</U>

Hope this helps.


----------------------------------------------------------------------

Comment By: Mad Druid (maddruid)
Date: 2007-01-23 12:12

Message:
Logged In: YES 
user_id=1488257
Originator: YES

This is still a problem for beta 6.  I forgot to mention the & symbol gets
printed as &amp; as well.

----------------------------------------------------------------------

Comment By: Mad Druid (maddruid)
Date: 2006-11-27 11:38

Message:
Logged In: YES 
user_id=1488257
Originator: YES

Is there any other information that I can provide for this bug?

----------------------------------------------------------------------

Comment By: Gilles Gagniard (jaile)
Date: 2006-11-17 07:13

Message:
Logged In: YES 
user_id=1040207
Originator: NO

I can confirm that this issue which appeared in 2.0.0 beta (everything
works in gaim 1.5.0) is still not resolved in beta5. I have exactly the
same problem than described her or in bug 1426401, when I'm chatting in a
meanwhile conference room (private messages work perfectly) with people
using either sametime connect or notesbuddy.

----------------------------------------------------------------------

Comment By: Mad Druid (maddruid)
Date: 2006-11-14 14:27

Message:
Logged In: YES 
user_id=1488257
Originator: YES

This only happens in conversations aka conferences aka multi-person-chats.
 This does NOT happen when I chat one person directly.

----------------------------------------------------------------------

Comment By: Mad Druid (maddruid)
Date: 2006-11-14 14:25

Message:
Logged In: YES 
user_id=1488257
Originator: YES

> When you send a <, what do you see?
I see &lt;

> When you send a <, what does the other person see?
Everyone in the conversation sees &lt;

> When the other person sends a <, what do you see?
If the other person is using gaim 2.0.0 beta x, I see &lt;
If the other person is using gaim 1.5.x, I see <
If the other person is using a real sametime client, I see <

----------------------------------------------------------------------

Comment By: Christopher (siege) O'Brien (taliesein)
Date: 2006-11-14 14:17

Message:
Logged In: YES 
user_id=77326
Originator: NO

Ok, I need some clarification on this. There are three different parts
here, and I need to know how each look, because I'm not sure which of the
three is acting incorrectly.

When you send a <, what do you see?
When you send a <, what does the other person see?
When the other person sends a <, what do you see?


----------------------------------------------------------------------

Comment By: Mad Druid (maddruid)
Date: 2006-11-14 13:17

Message:
Logged In: YES 
user_id=1488257
Originator: YES

One of my coworkers is using version 1.5.0 and it doesn't have the issue.
I don't know if that helps or not, but I thought I'd add it.

----------------------------------------------------------------------

Comment By: Mad Druid (maddruid)
Date: 2006-11-14 13:16

Message:
Logged In: YES 
user_id=1488257
Originator: YES

I upgraded to beta 5 and the issue is still there.

----------------------------------------------------------------------

Comment By: Christopher (siege) O'Brien (taliesein)
Date: 2006-11-14 13:10

Message:
Logged In: YES 
user_id=77326
Originator: NO

try beta 5

----------------------------------------------------------------------

You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=100235&aid=1596466&group_id=235

-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier.
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Gaim-bugs mailing list
Gaim-bugs@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gaim-bugs

Reply via email to