Bugs item #1652353, was opened at 2007-02-05 20:33
Message generated for change (Comment added) made by lingforum
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=100235&aid=1652353&group_id=235

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: solaris
Group: 2.0.0 beta 6
Status: Open
Resolution: None
Priority: 5
Private: No
Submitted By: lingforum (lingforum)
Assigned to: Nobody/Anonymous (nobody)
>Summary: Solaris (SunOS 5.10)  connect + errno not set

Initial Comment:
If I run a application which is using the gaim libraries from 2.0.0beta5 
release, the connection is failed with yahoo, msn servers.

I think, In Proxy.c file, proxy_connect_none function "connect" call is 
failing. But it does not set the errno. So it gets disconnected immediately.

If we comment the line
fcntl(connect_data->fd, F_SETFL, O_NONBLOCK);, it seems its working fine. Its 
connected immediately with yahoo, msn servers.

Is it means that setting NON_BLOCK is giving some problem?


----------------------------------------------------------------------

>Comment By: lingforum (lingforum)
Date: 2007-02-10 12:01

Message:
Logged In: YES 
user_id=1710963
Originator: YES

I found the solution.
If you are working on Multithreaded code, then you have to compile the
gaim with  -D_REENTRANT cppflag.
Then the errno will be set, if any system call failed.

----------------------------------------------------------------------

Comment By: lingforum (lingforum)
Date: 2007-02-06 15:21

Message:
Logged In: YES 
user_id=1710963
Originator: YES

I upgraded to gaim-2.0.0beta6 version. Still the problem exists.

----------------------------------------------------------------------

Comment By: Luke Schierer (lschiere)
Date: 2007-02-05 23:17

Message:
Logged In: YES 
user_id=28833
Originator: NO

I believe there were some bug fixes that affect solaris users in
particular in the beta6 release, does upgrading fix this? 

----------------------------------------------------------------------

Comment By: Luke Schierer (lschiere)
Date: 2007-02-05 23:17

Message:
Logged In: YES 
user_id=28833
Originator: NO

This bug was filed against an old version of gaim.  If you are
not using the lastest version, please upgrade.  If you are using
the latest version, and the bug persists, please indicate so and
reopen this bug.

----------------------------------------------------------------------

You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=100235&aid=1652353&group_id=235

-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier.
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Gaim-bugs mailing list
Gaim-bugs@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gaim-bugs

Reply via email to