Bugs item #1693715, was opened at 2007-04-03 19:35
Message generated for change (Comment added) made by lvysochyn
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=100235&aid=1693715&group_id=235

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: win32
Group: 2.0.0 beta 6
>Status: Open
Resolution: None
Priority: 5
Private: No
Submitted By: Leonid Vysochyn (lvysochyn)
Assigned to: Daniel Atallah (datallah)
Summary: Can't connect using http proxy

Initial Comment:
There is a problem when trying to connect using http proxy that requires 
authorization in Gaim 2.0.0 beta 6.
Gaim 1.5.0 works just fine with the same configuration options. So I believe 
something has changed in the latest version that prevents Gaim from setting up 
a connection.

Next is connection log from debug window.

connection: Connecting. gc = 0330FF10
dnsquery: Performing DNS lookup for kiev-isa-db.dbdc.luxoft.com
dnsquery: IP resolved for kiev-isa-db.dbdc.luxoft.com
proxy: Attempting connection to 192.168.172.2
proxy: Connecting to jabber.nnov.net:443 via kiev-isa-db.dbdc.luxoft.com:8080 
using HTTP
proxy: Connection in progress
proxy: Connected.
proxy: Using CONNECT tunneling for jabber.nnov.net:443
proxy: Proxy server replied with:
HTTP/1.1 407 Proxy Authentication Required ( The ISA Server requires 
authorization to fulfill the request. Access to the Web Proxy service is 
denied.  )

Via: 1.1 KIEV-ISA-DB

Proxy-Authenticate: Negotiate

Proxy-Authenticate: Kerberos

Proxy-Authenticate: NTLM

Proxy-Authenticate: Basic realm="kiev-isa-db.dbdc.luxoft.com"

Connection: close

Proxy-Connection: close

Pragma: no-cache

Cache-Control: no-cache

Content-Type: text/html

Content-Length: 723   
proxy: Connection attempt failed: Lost connection with server:
Windows socket error #10054
account: Disconnecting account 00D334C0
connection: Disconnecting connection 0330FF10
gaim_request_field_account_set_value: assertion `field->type == 
GAIM_REQUEST_FIELD_ACCOUNT' failed
connection: Destroying connection 0330FF10

----------------------------------------------------------------------

>Comment By: Leonid Vysochyn (lvysochyn)
Date: 2007-04-04 01:39

Message:
Logged In: YES 
user_id=1284515
Originator: YES

Hi Daniel,
I am using Gaim 2.0.0 beta 6.
The strange thing is that when I use Gaim 1.5.0 these same settings work
fine and Gaim connects successfully without any changes in configuration.
I tried this several times but the result is the same. Gaim 1.5.0 works
perfectly an Gaim 2.0.0 beta 6 fails to connect. I do not change any
account config files or anything else. No additional plugin installed. No
local firewall.

----------------------------------------------------------------------

Comment By: Daniel Atallah (datallah)
Date: 2007-04-03 19:59

Message:
Logged In: YES 
user_id=325843
Originator: NO

The proxy is closing the connection before gaim can try to authenticate, I
have no idea why this would happen.  Which version of GTK+ are you using?
Do you have a local software firewall?

----------------------------------------------------------------------

You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=100235&aid=1693715&group_id=235

-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys-and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
_______________________________________________
Gaim-bugs mailing list
Gaim-bugs@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gaim-bugs

Reply via email to