Old gajim ebuild (gentoo package) has optional dependency on
dev-python/notify-python, which is not available for usage with python
3.x. (I haven't tried doing this forcefully yet).

In translation files, I see mentions of python-notify:

#: ../src/features_window.py:79
msgid ""
"Requires python-notify or instead python-dbus in conjunction with "
"notification-daemon."

which (python-notify) seems to be this:

http://www.galago-project.org/files/releases/source/notify-python/

This is not updated since 2006 and e.g. debian packages quite match
that: version 0.1.1, python 2 only:

https://packages.debian.org/sid/python-notify

I don't believe this can work anymore for gajim from git master branch,
which requires python 3.5 or higher.

Alternative of using python-dbus & notification-daemon looks promising,
but I'd like to confirm with developers because whole quoted message can
be outdated just as python-notify thing itself.

Dear Gajim developers, could you please specify which are actual
dependencies around notifications?

Thanks a lot in advance.
_______________________________________________
Gajim-devel mailing list
Gajim-devel@gajim.org
https://lists.gajim.org/cgi-bin/listinfo/gajim-devel

Reply via email to