Hello,

some days ago, although I am fairly satisfied with my current XMPP client, Pidgin, I decided to try Gajim. It seems to be more close to use all the features that XMPP can offer.


There is something a bit unusual - although not a problem, just for what it is. The machine I use most is old, and has Ubuntu 10.04 in it. It runs fine, with all the programs I need and like and with a good performance. Great.

I am not too familiar with building processes, although I have done several of them (since and along years ago).

My current problem is that Gajim complains that it needs PyGTK 2.22+ to run. But I have PyGTK 2.24.0 installed!

The full story of my process of getting the Gajim source, installing and/or compiling and installing dependencies is detailed in a LinuxQuestions' thread. I will give you the thread address, but I will also summarize the important parts (for this discussion) right after:

http://www.linuxquestions.org/questions/linux-software-2/installing-needed-dependencies-for-gajim-0-16-7-from-source-in-ubuntu-10-04-a-4175606609

1. Downloaded Gajim 0.16.7 tarball: https://gajim.org/downloads.php?lang=en#source

2. Discovered dependency: installed python-nbxmpp ( https://dev.gajim.org/gajim/python-nbxmpp/ ) from source. A few more packages were installed through Synaptic (details in post #1).

3. To install PyGTK 2.24.0 ( http://ftp.gnome.org/pub/GNOME/sources/pygtk/2.24/ ), pygobject >= 2.21.3 was needed, tar.bz of 2.21.3 here: https://launchpad.net/pygobject/+milestone/2.21.3

4. PyGTK reported, before building:
==
The following modules will be built:
atk
pango

The following modules will NOT be built:
pangocairo
gtk
gtk.glade
gtk.unixprint

Numpy support: no
==

4.1. What should I do to build those in the "NOT" section? Are they used by Gajim?

4.2. PyGTK installer reported (full report on thread page 2, post #21):

Libraries have been installed in:
   /usr/local/lib/python2.6/dist-packages/gtk-2.0

5. PyGTK 2.24.0 is installed. Gajim still does not work, saying that it needs PyGTK 2.22+. What to do?

6. Someone said that "Gajim requires: pycrypto, pyOpenSSL, python-nbxmpp". I have not found this written in any Gajim file I downloaded. Does my build of Gajim includes support for security features?

I will be waiting for comments or (in the best possibility) the solution for my problem,

Dedeco

_______________________________________________
Gajim-devel mailing list
Gajim-devel@gajim.org
https://lists.gajim.org/cgi-bin/listinfo/gajim-devel

Reply via email to