Dear all,

I have worked out what caused this. Its down to the configuration of my cluster 
which has both an internal IP address and external IP address. Both of these 
resolve to the same hostname. 

Using the external IP address with the API worked, whereas the hostname did 
not. If any other user has this program, you need to modify line 58 of 
scripts/galaxy_messaging/server/ to point to your external IP 
address rather than the host name.

All the best!


-----Original Message-----
From: Nate Coraor [] 
Sent: 19 January 2011 16:43
To: Paszkiewicz, Konrad
Subject: Re: [galaxy-dev] API connection error

Paszkiewicz, Konrad wrote:
> Dear all,
> I'm getting the following error when trying to follow the instructions in the 
> API README file. Universe_wsgi.ini is pasted below.
> [galaxy@zeus api]$ ./ c43c7605ba60633a2ed60f46c12f354e 
> <urlopen error (111, 'Connection refused')>

Hi Konrad,

This should only occur if the Galaxy server itself is down.  Are you
able to access it via a web browser?


> Any suggestions would be very welcome.
> All the very best,
> Konrad.
> Dr Konrad Paszkiewicz
> Exeter Sequencing Service & Exeter Bioinformatics Service
> Biosciences, College of Life and Environmental Sciences
> University of Exeter
> Exeter
> EX4 4QD.

galaxy-dev mailing list

Reply via email to