I have (or rather had) a functional galaxy installation on a CentOS box running 
python 2.4. I did an mecurial update for the first time and broke my 
installation. It looks like some eggs are getting out of date and when I run 
scramble.py I get an error (see below). I'm guessing this is because scramble 
expects python 2.5 or above for the import (import in 2.4 I don't believe takes 
arguments).

My question is does galaxy really still support 2.4 and should I move to python 
2.7 (the current stable version) because the wiki just mentions versions 2.4 to 
2.6 as being supported.

 -John

run_scramble_script(): Executing in 
/home/galaxy/galaxy_dist/scripts/scramble/build/py2.4/python_daemon:
  /usr/bin/python -ES scramble.py
Traceback (most recent call last):
  File "scramble.py", line 29, in ?
    execfile( "setup.py", globals(), locals() )
  File "setup.py", line 22, in ?
    main_module = __import__(main_module_name, fromlist=['version'])
TypeError: __import__() takes no keyword arguments
scramble(): Egg already exists, remove to force rebuild:
  /home/galaxy/galaxy_dist/eggs/nose-0.11.1-py2.4.egg
scramble(): Egg already exists, remove to force rebuild:
  /home/galaxy/galaxy_dist/eggs/sqlalchemy_migrate-0.5.4-py2.4.egg
scramble(): Egg already exists, remove to force rebuild:
  /home/galaxy/galaxy_dist/eggs/WebOb-0.8.5-py2.4.egg
scramble(): Egg already exists, remove to force rebuild:
  /home/galaxy/galaxy_dist/eggs/PasteScript-1.7.3-py2.4.egg
Traceback (most recent call last):
  File "scripts/scramble.py", line 23, in ?
    eggs = c.scramble()
  File "/home/galaxy/galaxy_dist/lib/galaxy/eggs/scramble.py", line 243, in 
scramble
    raise last_exc # only 1 failure out of the crate, be more informative
galaxy.eggs.scramble.ScrambleFailure: run_scramble_script(): Egg build failed 
for python_daemon 1.5.5


_______________________________________________
galaxy-dev mailing list
galaxy-dev@lists.bx.psu.edu
http://lists.bx.psu.edu/listinfo/galaxy-dev

Reply via email to