On Mar 2, 2011, at 11:05 AM, Peter Cock wrote:

> On Wed, Mar 2, 2011 at 3:42 PM, Peter Cock <p.j.a.c...@googlemail.com> wrote:
>> 
>> P.S. I do like the color highlighting and live substitution of
>> the workflow parameters into each tool step that uses them.
>> Very slick!
>> 
> 
> That was the good news. Now the bad news - two bug reports.
> 
> Firstly if you clear the workflow parameter (leaving it empty), then
> the caption is used for the highlighted placeholders BUT only the
> first word is used, e.g.
> 
> ${Minimum read length (after any clipping)}
> 
> Initially the the placeholders show "Minimum read length (after any
> clipping)", and if you enter a value like "30" then "30" is shown. If
> you then edit the field to become empty, the placeholder now
> shows just "Minimum".
> 
> Furthermore, if I leave my workflow parameters empty, and
> press execute, I get a traceback ending with:
> 
> AttributeError: 'WorkflowStep' object has no attribute 'module'
> 
> Since an empty value is valid for some tools for some parameters
> (e.g. optional text fields) I would have expected any error later -
> from the tools themselves if they don't like the empty value.
> 
> Peter

Thanks for both the compliment and the bug reports, I should have these fixed 
shortly.  I hadn't actually anticipated long strings being used as parameters, 
but it should definitely work, and I can see where it'd be useful for comments 
like in your situation!

-Dannon
_______________________________________________
To manage your subscriptions to this and other Galaxy lists, please use the 
interface at:

  http://lists.bx.psu.edu/

Reply via email to