On 3/17/11 3:40 PM, Jeremy Goecks wrote:


    Hi all - I'm running Galaxy on my Redhat linux cluster.  When I run
    cufflinks from the shell I get the error/warning:

    cufflinks: /usr/lib64/libz.so.1: no version information available
    (required by cufflinks)


    but it still seems to run ok.  It looks like Galaxy is choking on
    this.  I tried compling cufflinks manually but that was more
    troublesome.  Is there a way I can get Galaxy to ignore this error
    and continue?


Ryan,

There's currently no way to tell Galaxy to ignore some error messages
and not others; we're working on this functionality but it's far from
being done*. Unfortunately, your best bet is to compile Cufflinks on
your system. FYI, here's a technical description of this problem:
http://seqanswers.com/forums/showthread.php?t=8042


*To detect particular errors, we envision XML elements in a tool's
output definition that use regular expressions to identify errors
amongst a program's output. We think this is the right approach, but we
haven't started implementing it yet. You are welcome to do so; we
welcome code contributions from the community.

Thanks,
J.

ok - I managed to compile cufflinks myself. When I run it I get a line of output that reads "linked against Boost version 104601". When I run cufflinks in Galaxy, Galaxy complains about this line being an error.

Hmmm.  How is cufflinks running in the public version of galaxy?
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

 http://lists.bx.psu.edu/

Reply via email to