Hi,

Just a note here.  So far, I have no success trying to login from the IE8 
browser.  It happens to my colleagues as well.

So I will try the next stable release of galaxy with the login fix.

Thanks for making galaxy, it is very useful!

Best regards,
Chee Seng

From: Luobin Yang [mailto:yangl...@isu.edu]
Sent: Wednesday, March 16, 2011 12:01 AM
To: Nate Coraor
Cc: CHAN Chee Seng; golha...@umdnj.edu; galaxy-...@bx.psu.edu
Subject: Re: [galaxy-dev] Login problem.

Hi, Nate,

I downloaded the development code base and I didn't see the problem anymore on 
my machines. Thanks for fixing it :-)

Luobin
On Tue, Mar 15, 2011 at 9:30 AM, Nate Coraor 
<n...@bx.psu.edu<mailto:n...@bx.psu.edu>> wrote:
CHAN Chee Seng wrote:
> Hi Ryan,
>
> Thanks for sharing the work around.
>
> I had the same problem.  I am running galaxy with mysql server.  I tested on
> 1. Firefox on a linux box
> 2. IE and firefox on a windows box.
>
> I tried restarting galaxy and the apache httpd server and my client machines 
> and nothing worked.
>
> Finally your solution worked for firefox on both platforms but IE still has 
> this problem.  That's fine with me, but some of my users are using IE.  :P  I 
> have cleared all histories and cache on IE too and still have this problem.
>
> I wonder what's caused this.  It was working fine before and suddenly this 
> problem pops up.  Now I can't duplicate the problem on the Firefoxes.
Hi all,

Unless I am mistaken, I believe the problem here is a redirection bug
which was fixed in the development code base last week.  The previous
behavior looked like this:

 1. Click the logout link from an interface without the left and right
    panels, like the Data Library list.
 2. While still on the page displaying the logout message, click the
    login link, and log in.
 3. Once logged in, Galaxy redirects you to the last page you were
    visiting... the logout page.
 4. The logout page logs you out and you are right back where you
    started.

If you find that all of this behavior disappears if you log in from any
page other than the logout page, then it is being caused by the bug
above, and will be fixed in the next stable release of Galaxy.

--nate

>
> Thanks.
>
> Best regards,
> Chee Seng
>
> From: 
> galaxy-dev-boun...@lists.bx.psu.edu<mailto:galaxy-dev-boun...@lists.bx.psu.edu>
>  
> [mailto:galaxy-dev-boun...@lists.bx.psu.edu<mailto:galaxy-dev-boun...@lists.bx.psu.edu>]
>  On Behalf Of Luobin Yang
> Sent: Tuesday, March 15, 2011 3:43 AM
> To: golha...@umdnj.edu<mailto:golha...@umdnj.edu>
> Cc: galaxy-...@bx.psu.edu<mailto:galaxy-...@bx.psu.edu>
> Subject: Re: [galaxy-dev] Login problem.
>
> Hi, Ryan,
>
> Thanks for sharing your experience. It seems the issue is more serious when I 
> use Chrome rather than Firefox.
>
> Luobin
>
> On Fri, Mar 11, 2011 at 8:03 PM, Ryan Golhar 
> <golha...@umdnj.edu<mailto:golha...@umdnj.edu><mailto:golha...@umdnj.edu<mailto:golha...@umdnj.edu>>>
>  wrote:
> Loubin,
>
> I had this same problem.  I think its a caching issue.  After you log out, 
> try visiting a different page or click on "Analyze Data", then click on log 
> in.  Once I navigated off the login page then came back, I was able to login.
>
> Ryan
>
>
> On 3/11/11 2:17 PM, Luobin Yang wrote:
> Dear Galaxy development team,
>
> I've got a problem using the login function of Galaxy.
>
> So I downloaded a copy of Galaxy distribution and installed it on a
> local machine, then I installed PostgreSQL on this machine and made the
> necessary changes to the universe_wsgi.ini file and Galaxy is able to
> the use the PostgreSQL database to store information. I was able to
> register a user account and then I could login to the system for the
> first time, but after I logout and login again, the system always says
> that I am logged out. I checked the log file of Postgresql and the log
> file of Galaxy system, there is no error message indicating what
> happened at all.
>
> I restarted Postgresql database and Galaxy system and then I was able to
> login, but after I logged out, I can not login again! Have you guys met
> this kind of problem before? Any suggestions on what could be the cause
> of this problem?
>
> Thanks so much!
> Luobin
>
>
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>
>   http://lists.bx.psu.edu/
>

> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>
>   http://lists.bx.psu.edu/

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to