Since we're shooting in the dark here, best to try and understand what's the 

Add the following line to the beginning of "sam_to_bam.py":
 import traceback

and add the following line to "sam_to_bam.py" line 156 (before the call to 

Hopefully this will print out which exception you're getting, and where is it 
thrown from.


Ryan Golhar wrote, On 04/06/2011 06:05 PM:
> Alright, I'm at a loss
> I can run the sam to bam converter on a small sam file but not a big
> sam file.  The small SAM file is only 65K, the big SAM file is 44G.
> I have more than 8TB of free space.
> Running the job script from the shell results in the small conversion
> succeeding and the big one failing.  The return code from samtools in
> both instances in 0 so I can't for any reason think of why there the
> script is getting caught in an exception.
> I even added a write statement to stdout to double-check the return
> code and stderr message and they are the same in both cases.
> Why is this failing in one case and not the other?  I'm stuck.
> Help....
> Ryan
> On 4/6/11 4:58 PM, Ryan Golhar wrote:
>> So it looks like I can get small sam files converted to bam files,
>> but not large sam files (~50GB-80GB). I'm still trying to debug
>> this, but not sure what's going on.
>> Has anyone else run into anything like this?
>> On 4/6/11 10:08 AM, Ryan Golhar wrote:
>>> Any ideas why I would get this? If I run the sam_to_bam python
>>> script from the shell, I get the same error:
>>> (galaxy_env)[galaxy@vail pbs]$ sh 471.sh Linux vail
>>> 2.6.18-194.3.1.el5xen #1 SMP Sun May 2 04:26:43 EDT 2010 x8 6_64
>>> x86_64 x86_64 GNU/Linux Samtools Version: 0.1.14 (r933:170) Error
>>> extracting alignments from 
>>> (/home/galaxy/galaxy-dist/database/files/000/dataset_785.dat),
>>> However running the samtools command works fine
>>> On 4/5/11 5:58 PM, Ryan Golhar wrote:
>>>> I've performed an alignment using BWA on a file of paired-end
>>>> illumina reads. The SAM file looks fine, and contains header
>>>> information. I'm converting it to BAM using the sam to bam
>>>> converter, however it consistently errors out after running for
>>>> a while. The error is:
>>>> "Error extracting alignments from 
>>>> (/home/galaxy/galaxy-dist/database/files/000/dataset_785.dat),
>>>> "
>>>> but no error is provided. Looking at the sam_to_bam.py on line
>>>> 156 is where the error is thrown. Nothing is in e (I think).
>>>> BTW - If I run the samtools command from the shell by hand, the
>>>> BAM file is created properly. I do see information on stderr:
>>>> $ samtools view -bt /data/genomes/H_sapiens/hg19/hg19.fa.fai
>>>> -o /tmp/killme.bam 
>>>> /home/galaxy/galaxy-dist/database/files/000/dataset_785.dat 
>>>> [samopen] SAM header is present: 25 sequences.
>>>> I'm using samtools version 0.1.14 (r933:170) on Linux, 64-bit.
>>>> What do I do?
>>>> Ryan

Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:


Reply via email to