On Mon, Apr 18, 2011 at 6:27 PM, Jeremy Goecks wrote:
> This is a runtime error, not an update error; it is occurring because we
> mistakenly committed code that is not compliant with python 2.4

Yes, sorry: you're technically correct. I should have said "Problem
after update" in my subject. ;-)

> Here are your options to fix this error:
> (1) update your python version from 2.4 to 2.5 or 2.6;

Unfortunately, not an option: I am trying to keep my CentOS 5
compatible with the downstream vendor and Python 2.4.3 is the
installed version.

> (2) update your installation from galaxy-central; specifically, you'll need
> changeset 5370:1cb94990d839

My preference, but as I said in my original post, I'm not too familiar
with Mercurial, so what is the syntax for pulling a single changeset
from a repository from other than from where I originally "cloned"? I
tried:

hg pull -u -r 5370:1cb94990d839 https://bitbucket.org/galaxy/galaxy-central

and got:

abort: unknown revision '5370:1cb94990d839'!

When I dropped the "5370:", I got 15 changesets and it wanted a
database upgrade when I restarted. Luckily, I was testing on a copy.

> Sorry for the inconvenience.

No worries.
--
Olen

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to