Dear Galaxy Team,

I just updated my local instance of galaxy, and now I have a problem
with the "DRMAA_python" egg, which makes it impossible to run jobs on
our SGE cluster. I get the following error message after executing "run.sh":

____________________

Traceback (most recent call last):
  File "/rahome/webservices/galaxy_test/lib/galaxy/jobs/__init__.py",
line 1028, in _load_plugin
    module = __import__( module_name )
  File "/rahome/webservices/galaxy_test/lib/galaxy/jobs/runners/sge.py",
line 28, in <module>
    raise Exception( egg_message % str( e ) )
Exception:

The 'sge' runner depends on 'DRMAA_python' which is not installed.  Galaxy's
"scramble" system should make this installation simple, please follow the
instructions found at:

  http://bitbucket.org/galaxy/galaxy-central/wiki/Config/Cluster

Additional errors may follow:
['DRMAA_python']

____________________

I read the instructions and set the corresponding environment variable
to tell galaxy about the location of the DRMAA library using the command:

export DRMAA_LIBRARY_PATH=/opt/sge-6.1/lib/lx24-x86/libdrmaa.so.1.0

When I started galaxy again, the same error message (see above)
occurred. I also tried to scramble the DRMAA_python egg, which resulted
in the following error message:

____________________

fetch_one(): Using existing source, remove to download again:

/rahome/webservices/galaxy_test/scripts/scramble/archives/DRMAA_python-0.2.tar.gz
unpack_source(): Removing old build directory at:

/rahome/webservices/galaxy_test/scripts/scramble/build/py2.6-linux-i686-ucs4/DRMAA_python
unpack_source(): Unpacked to:

/rahome/webservices/galaxy_test/scripts/scramble/build/py2.6-linux-i686-ucs4/DRMAA_python
copy_build_script(): Using build script
/rahome/webservices/galaxy_test/scripts/scramble/scripts/DRMAA_python.py
run_scramble_script(): Beginning build
run_scramble_script(): Executing in
/rahome/webservices/galaxy_test/scripts/scramble/build/py2.6-linux-i686-ucs4/DRMAA_python:
  /usr/bin/python26 scramble.py
main(): Patching setup.py
running bdist_egg
running egg_info
creating DRMAA_python.egg-info
writing DRMAA_python.egg-info/PKG-INFO
writing top-level names to DRMAA_python.egg-info/top_level.txt
writing dependency_links to DRMAA_python.egg-info/dependency_links.txt
writing manifest file 'DRMAA_python.egg-info/SOURCES.txt'
reading manifest file 'DRMAA_python.egg-info/SOURCES.txt'
writing manifest file 'DRMAA_python.egg-info/SOURCES.txt'
installing library code to build/bdist.linux-i686/egg
running install_lib
running build_py
creating build
creating build/lib.linux-i686-2.6
copying DRMAA.py -> build/lib.linux-i686-2.6
copying cDRMAA.py -> build/lib.linux-i686-2.6
running build_ext
building '_cDRMAA' extension
creating build/temp.linux-i686-2.6
gcc -pthread -fno-strict-aliasing -DNDEBUG -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic
-fasynchronous-unwind\
-tables -D_GNU_SOURCE -fPIC -fwrapv -fPIC -I/opt/sge-6.1/include
-I/usr/include/python2.6 -c cDRMAA_wrap.c -o
build/temp.linux-i686-2.6/cDRMAA_wrap.o -Wno-unused
cDRMAA_wrap.c:13:20: error: Python.h: No such file or directory
cDRMAA_wrap.c:358: error: expected specifier-qualifier-list before
‘PyObject’
cDRMAA_wrap.c:364: error: expected specifier-qualifier-list before
‘PyObject_HEAD’
...
error: command 'gcc' failed with exit status 1
Traceback (most recent call last):
  File "scripts/scramble.py", line 44, in <module>
    egg.scramble()
  File "/rahome/webservices/galaxy_test/lib/galaxy/eggs/scramble.py",
line 57, in scramble
    self.run_scramble_script()
  File "/rahome/webservices/galaxy_test/lib/galaxy/eggs/scramble.py",
line 206, in run_scramble_script
    raise ScrambleFailure( self, "%s(): Egg build failed for %s %s" % (
sys._getframe().f_code.co_name, self.name, self.version ) )
galaxy.eggs.scramble.ScrambleFailure: run_scramble_script(): Egg build
failed for DRMAA_python 0.2

____________________


I would very much appreciate your help in fixing this problem.

Kind regards,
Johannes

-- 
Dipl.-Inf. (Bioinf.) Johannes Eichner
Univ. Tuebingen, WSI-RA, Sand 1, D-72076 Tuebingen, Germany
Phone: (+49/0) 7071 / 29 70436  Fax: (+49/0) 7071 / 29 5091
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to