On May 17, 2011, at 11:35 AM, Nate Coraor wrote:

> Shantanu Pavgi wrote:
>> 
>> 
>> I am trying to configure galaxy with sge/drmaa scheduler. The galaxy process 
>> is starting up fine without any drmaa configuration. However the galaxy 
>> daemon doesn't start properly when I add drmaa configuration lines as shown 
>> below. I have set SGE_ROOT and DRMAA_LIBRARY_PATH variables properly. Am I 
>> missing something important here?
> 
> Could you provide the output of starting Galaxy with the drmaa options
> enabled?  You may want to start it in the foreground (without --daemon)
> to capture any messages which are not output to paster.log
> 

It's working now. I hadn't set SGE_QMASTER_PORT env variable earlier. I am 
guessing galaxy-start process got hung while attempting to connect with 
'unknown/null' SGE port. I didn't see any error related to SGE_QMASTER_PORT in 
the log file, however I did notice that galaxy checks for SGE_ROOT variable 
value. We are using a fresh SGE submit host install here and hence we may see 
some initial environment configuration issues. 

Another community member Ross Lazarus suggested me to try sge as job_runner 
setting instead of pbs or drmaa. This printed out error message related to 
SGE_QMASTER_PORT in the logs. I set this variable and then tried drmaa setting 
again which worked fine this time. Thanks for the help Ross and Nate. 

--
Shantanu. 



___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to