Hi again,

I think I've figured out the bug... it seems that you cannot do
selected="true" on any options with a select multiple input param.  If you
remove those then everything displays properly, but unfortunately you cannot
configure a set of default selected options for when the form comes up.

best,
Leandro

On Thu, May 19, 2011 at 7:12 PM, Leandro Hermida <soft...@leandrohermida.com
> wrote:

> I have the following tool input parameter:
>
> <param name="columns" type="select" multiple="true" label="Select which
> columns to output">
>     <option>SIZE</option>
>     <option>ES</option>
>     <option selected="true">NES</option>
>     <option>NOM p-val</option>
>     <option selected="true">FDR q-val</option>
>     <option>FWER p-val</option>
>     <option selected="true">RANK AT MAX</option>
>     <option>LEADING EDGE</option>
> </param>
>
> It displays a single select drop-down menu, is this a bug or did I
> configure something wrong?
>
> To check I added display="checkboxes" to the param above and now it
> displays a multi select but when the form loads everything comes up checked
> it doesn't obey any of the selected="true"? Is this also a bug or must it be
> done a different way?
>
> regards,
> Leandro
>
>
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to