Hi Leandro,

The Galaxy Team has recently been preparing for and traveling in advance
of the Galaxy Community Conference, which begins today.  Unfortunately I
don't have an answer for you, but when we're all back at work next week,
someone should be able to respond.

Thanks,
--nate

Leandro Hermida wrote:
> Hi again,
> 
> Very sorry to ask again, just gotten no repsonse, but is this a Galaxy bug
> or does anyone have a functioning tool that takes multiple datasets as an
> input parameter??? i.e.
> 
> <param type="data" multiple="true" ...  />
> 
> regards,
> Leandro
> 
> On Thu, May 19, 2011 at 7:15 PM, Leandro Hermida <soft...@leandrohermida.com
> > wrote:
> 
> > Hi again,
> >
> > I tried changing the format to txt and tabular which I have other datasets
> > in my history and still the same error and stack trace in Galaxy.
> >
> > Is it possible at all to have a select multiple of datasets as an input
> > parameter??
> >
> > best,
> > Leandro
> >
> >
> > On Thu, May 19, 2011 at 6:59 PM, Leandro Hermida <
> > soft...@leandrohermida.com> wrote:
> >
> >> Hi Galaxy developers,
> >>
> >> Something seems maybe to be wrong with the format="html" type... I forgot
> >> to add before that my tool input param the format="html" attribute:
> >>
> >> <param type="data" multiple="true" format="html" name="input1" />
> >>
> >> In another tool I have it outputs format="html" and this works and
> >> displays in Galaxy just fine. I would like to use multiple of these output
> >> datasets in my history as the input for this other tool but something seems
> >> to be wrong if you try to do this?
> >>
> >> a bit lost,
> >> Leandro
> >>
> >>
> >> On Thu, May 19, 2011 at 3:30 PM, Leandro Hermida <
> >> soft...@leandrohermida.com> wrote:
> >>
> >>> Hi,
> >>>
> >>> I have a tool where the input is multi-select of datasets, e.g.:
> >>>
> >>> <param type="data" multiple="true" name="input1" />
> >>>
> >>> I tested it to see what it would pass to my command and I get the
> >>> following debug page and error in Galaxy:
> >>>
> >>> AttributeError: 'list' object has no attribute 'missing_meta'
> >>>
> >>> The last part of the stack trace looks like:
> >>>
> >>> >>  validator.validate( value, history )
> >>> Module galaxy.tools.parameters.validation:185 in validate
> >>>
> >>> history <galaxy.model.History object at 0xb8ea190>
> >>> self        <galaxy.tools.parameters.validation.MetadataValidator object
> >>> at 0xb8e6250>
> >>> value [<galaxy.model.HistoryDatasetAssociation object at 0xa255550>,
> >>> <galaxy.model.HistoryDataset ... Association object at 0xb8ea210>]
> >>>
> >>> >>  if value and value.missing_meta( check = self.check, skip = self.skip
> >>> ):
> >>> AttributeError: 'list' object has no attribute 'missing_meta'
> >>>
> >>> What am I doing wrong?
> >>>
> >>> regards,
> >>> Leandro
> >>>
> >>>
> >>
> >

> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
> 
>   http://lists.bx.psu.edu/

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to