Any other ideas?  I can run galaxy-central but I'd like to work with the stable 
galaxy if possible.

Because earlier revs of galaxy-dist startup fine for me I went through the 
exercise of using hg bisect to mark my last pull rev of 5355 as good and 5585 
as bad I went through some revs, each time attempting to start the server.  The 
bad revs failed to startup with ValueError 'numpy.dtype' exception where the 
good revs started fine.

So according to hg bisect:

The first bad revision is:
changeset:   5410:0194ab30a730
user:        Nate Coraor <n...@bx.psu.edu>
date:        Mon Apr 18 16:42:12 2011 -0400
summary:     Update bx-python to the tip.

I'm not sure from the diff what change in that revision could cause this error. 
 

What am I missing?  Is anyone else having trouble running the latest 
galaxy-dist?

~Mike

On Jun 15, 2011, at 12:18 PM, Nate Coraor wrote:

> Michael Steder wrote:
>> I'm just following the documentation here: 
>> https://bitbucket.org/galaxy/galaxy-central/wiki/GetGalaxy
>> 
>> And I ran into the following error:
>> 
>> $ hg clone https://bitbucket.org/galaxy/galaxy-dist
>> $ cd galaxy-dist
>> $ sh run.sh
>> Fetch successful.
>> Traceback (most recent call last):
>>  File "/Users/steder/GO/GoGalaxy/galaxy-dist/lib/galaxy/web/buildapp.py", 
>> line 81, in app_factory
>>    from galaxy.app import UniverseApplication
>>  File "/Users/steder/GO/GoGalaxy/galaxy-dist/lib/galaxy/app.py", line 11, in 
>> <module>
>>    from galaxy.tools.imp_exp import load_history_imp_exp_tools
>>  File 
>> "/Users/steder/GO/GoGalaxy/galaxy-dist/lib/galaxy/tools/imp_exp/__init__.py",
>>  line 6, in <module>
>>    from galaxy.web.base.controller import UsesHistory
>>  File 
>> "/Users/steder/GO/GoGalaxy/galaxy-dist/lib/galaxy/web/base/controller.py", 
>> line 12, in <module>
>>    from galaxy.visualization.tracks.data_providers import get_data_provider
>>  File 
>> "/Users/steder/GO/GoGalaxy/galaxy-dist/lib/galaxy/visualization/tracks/data_providers.py",
>>  line 16, in <module>
>>    from bx.arrays.array_tree import FileArrayTreeDict
>>  File "numpy.pxd", line 119, in init bx.arrays.array_tree 
>> (lib/bx/arrays/array_tree.c:11323)
>> ValueError: numpy.dtype does not appear to be the correct type object
>> 
>> I was able to run the previous stable version of Galaxy.  Is there something 
>> I can do to get galaxy-dist running?
> 
> Hi Mike,
> 
> I'm moving this over to galaxy-dev since it deals with a local
> installation.
> 
> It should be working, this would have been a problem for a short time
> using galaxy-central, but should not have affected -dist.  Could you
> send the output of:
> 
>  python ./scripts/get_platforms.py
>  python -V
> 
>> 
>> Should I be running galaxy-central instead?
> 
> No, galaxy-dist is fine (and should be less prone to issues due to
> cloning/updating at the wrong moment).
> 
> Thanks,
> --nate
> 
>> 
>> ~Mike
>> ___________________________________________________________
>> The Galaxy User list should be used for the discussion of
>> Galaxy analysis and other features on the public server
>> at usegalaxy.org.  Please keep all replies on the list by
>> using "reply all" in your mail client.  For discussion of
>> local Galaxy instances and the Galaxy source code, please
>> use the Galaxy Development list:
>> 
>>  http://lists.bx.psu.edu/listinfo/galaxy-dev
>> 
>> To manage your subscriptions to this and other Galaxy lists,
>> please use the interface at:
>> 
>>  http://lists.bx.psu.edu/


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to