Hi, 

I recently downloaded galaxy and had some problems installing it on my machine 
(running Mac OSX 10.6.7 ).  I've found a workaround to my problem, but I 
thought I should post here in case it is useful.  

I obtained the standard galaxy distribution using

hg clone https://bitbucket.org/galaxy/galaxy-dist/

I then tried running sh run.sh but got;

Traceback (most recent call last):
  File "/Users/iracooke/Sources/galaxy-dist/lib/galaxy/web/buildapp.py", line 
81, in app_factory
    from galaxy.app import UniverseApplication
  File "/Users/iracooke/Sources/galaxy-dist/lib/galaxy/app.py", line 11, in 
<module>
    from galaxy.tools.imp_exp import load_history_imp_exp_tools
  File 
"/Users/iracooke/Sources/galaxy-dist/lib/galaxy/tools/imp_exp/__init__.py", 
line 6, in <module>
    from galaxy.web.base.controller import UsesHistory
  File "/Users/iracooke/Sources/galaxy-dist/lib/galaxy/web/base/controller.py", 
line 12, in <module>
    from galaxy.visualization.tracks.data_providers import get_data_provider
  File 
"/Users/iracooke/Sources/galaxy-dist/lib/galaxy/visualization/tracks/data_providers.py",
 line 16, in <module>
    from bx.arrays.array_tree import FileArrayTreeDict
  File "numpy.pxd", line 119, in init bx.arrays.array_tree 
(lib/bx/arrays/array_tree.c:11323)
ValueError: numpy.dtype does not appear to be the correct type object


I googled this error and found a post suggesting that I try virtualenv ... I 
tried that but it made no difference.  

Python --version returns 
2.6.1

After some digging I tried rescrambling the numpy and then the bx_python egg.  
After rescrambling the latter sh run.sh worked. 

Anyway I'm not sure if other mac users have had similar problems.  In my case 
I'm pretty sure I had installed things with easy_install in the past ...but I 
assume using virtualenv would have solved that problem.

Ira


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to