Hello

I'm configuring a personal Galaxy instance with NGS tools (precursor to setting up a local production version) and had some difficulty getting the Bfast mapper (NGS Mapping -> Map with BFAST) to pick up the reference genomes from the bfast_indexes.loc file.


I'm using a hg clone of galaxy-dist, and declared the reference indexes in tab-delimited format, as indicated by the comments in bfast_indexes.loc.sample. However the bfast_wrapper.xml seems to expect some kind of comma-separated value? Anyway patching bfast_wrapper.xml thusly fixed the problem for me:

--- bfast_wrapper.xml.orig      2011-06-23 09:56:54.008898765 +0100
+++ bfast_wrapper.xml   2011-06-23 10:01:30.048840835 +0100
@@ -62,8 +62,6 @@
       <when value="indexed">
<param name="indices" type="select" label="Select a reference genome index set">
           <options from_data_table="bfast_indexes">
-            <filter type="multiple_splitter" column="2" separator=","/>
- <filter type="param_value" column="2" ref="input1" ref_attribute="extension"/>
             <filter type="sort_by" column="3"/>
<validator type="no_options" message="No indexes are available for the selected input dataset"/>
           </options>

I can imagine that using a different format in bfast_indexes.loc should also work, but tab-delimited seems more consistent with the other loc files.

Apologies if this is a known issue (I couldn't find anything in the GMOD archive, and neither bfast_wrapper.xml or bfast_indexes.loc.sample seem to have changed wrt this issue in Galaxy Central), or if I've missed something really obvious.

Thanks for your help, best wishes

Peter

--
Peter Briggs peter.bri...@manchester.ac.uk
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

 http://lists.bx.psu.edu/

Reply via email to